Bug 971117 - No processing for event 'report_Uploader' is defined
No processing for event 'report_Uploader' is defined
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
AcceptedFreezeException
:
: 974080 (view as bug list)
Depends On:
Blocks: F19-accepted/F19FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-06-05 14:07 EDT by Mark Hamzy
Modified: 2016-11-30 19:44 EST (History)
11 users (show)

See Also:
Fixed In Version: abrt-2.1.5-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 02:13:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Hamzy 2013-06-05 14:07:38 EDT
Description of problem:
When an exception is reported by anaconda. You cannot create a local tarball of the exception

Version-Release number of selected component (if applicable):
python-meh-0.24-1.fc19.noarch
libreport-anaconda-2.1.4-5.fc19.ppc64
libreport-python-2.1.4-5.fc19.ppc64
libreport-filesystem-2.1.4-5.fc19.ppc64

How reproducible:
Always

Steps to Reproduce:
0. Cause an anaconda exception
1. Choose "Upload the problem data to a server"
2. Choose "Configure Report uploader"
3. Enter "file:///tmp/file.tar.gz"
4. Fill out remaining screen.

Actual results:
Fails with processing failed.
No processing for event 'report_Uploader' is defined.

Expected results:
Should create a local file.

Additional info:
Comment 1 Jakub Filak 2013-06-10 08:25:19 EDT
Fixed in upstream:

commit 99c9409b109537df1fa1344b1310e8c229718762
Author: Jakub Filak <jfilak@redhat.com>
Date:   Thu Jun 6 08:03:58 2013 +0200

    make the uploader event available for all report types
    
    Closes rhbz#971117
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Martin Milata <mmilata@redhat.com>
Comment 2 Kamil Páral 2013-06-13 08:12:03 EDT
*** Bug 974080 has been marked as a duplicate of this bug. ***
Comment 3 Kamil Páral 2013-06-13 08:13:30 EDT
Transferred blocker nomination from bug 974080.
Comment 4 Adam Williamson 2013-06-13 11:40:59 EDT
kparal: the criterion is explicitly written *not* to require saving to a file to work, it's not an oversight. Saving to file isn't terribly important as you can just get the files from /tmp.
Comment 5 Kamil Páral 2013-06-13 12:03:54 EDT
In that case changing to a FreezeException request. The patch is ready.

Jakub, please send a new package to updates-testing, thank you.
Comment 6 Fedora Update System 2013-06-14 18:23:52 EDT
abrt-2.1.5-1.fc19,libreport-2.1.5-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/abrt-2.1.5-1.fc19,libreport-2.1.5-1.fc19
Comment 7 Fedora Update System 2013-06-15 13:04:37 EDT
Package abrt-2.1.5-1.fc19, libreport-2.1.5-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.1.5-1.fc19 libreport-2.1.5-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10886/abrt-2.1.5-1.fc19,libreport-2.1.5-1.fc19
then log in and leave karma (feedback).
Comment 8 Adam Williamson 2013-06-17 15:03:58 EDT
Discussed at 2013-06-17 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-17/f19final-blocker-review-6.2013-06-17-16.01.log.txt . Accepted as a freeze exception issue: per c#5 this isn't required functionality, but we'd like to have it working, and it can't be fixed post-release.
Comment 9 Fedora Update System 2013-06-18 02:13:57 EDT
abrt-2.1.5-1.fc19, libreport-2.1.5-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Kamil Páral 2013-06-18 06:27:09 EDT
Verified fixed with F19 TC5 DVD.

Note You need to log in before you can comment on or make changes to this bug.