Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 974080 - Can't save exception report as a file
Can't save exception report as a file
Status: CLOSED DUPLICATE of bug 971117
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19Blocker/F19FinalBlocker
  Show dependency treegraph
 
Reported: 2013-06-13 07:52 EDT by Kamil Páral
Modified: 2013-06-13 08:12 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 08:12:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libreport configuration (58.69 KB, image/png)
2013-06-13 07:52 EDT, Kamil Páral
no flags Details
libreport error (38.74 KB, image/png)
2013-06-13 07:52 EDT, Kamil Páral
no flags Details
journal from the running system, after libreport failed (137.59 KB, text/plain)
2013-06-13 07:53 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-06-13 07:52:02 EDT
Description of problem:
I used https://fedoraproject.org/wiki/QA:Testcase_Anaconda_save_traceback_to_bugzilla to trigger a fake exception on F19 TC3 DVD x86_64. I tried to save it to a file. It failed with error:

> No processing for event 'report_Uploader' is defined

Reporting to Bugzilla works.

Version-Release number of selected component (if applicable):
F19 TC3 DVD x86_64

How reproducible:
always

Steps to Reproduce:
1. kill -USR1 `cat /var/run/anaconda.pid`
2. "upload data to server"
3. use "file:///tmp/" location
4. confirm everything, see said error
Comment 1 Kamil Páral 2013-06-13 07:52:36 EDT
Created attachment 760630 [details]
libreport configuration
Comment 2 Kamil Páral 2013-06-13 07:52:45 EDT
Created attachment 760631 [details]
libreport error
Comment 3 Kamil Páral 2013-06-13 07:53:04 EDT
Created attachment 760632 [details]
journal from the running system, after libreport failed
Comment 4 Kamil Páral 2013-06-13 07:54:48 EDT
We have the following criterion:
"The installer must be able to report failures to Bugzilla, with appropriate information included. "
http://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria#Failure_reporting

However, we might consider saving to a file equally important. Some organizations may not want to save errors to Fedora Bugzilla.
Comment 5 Kamil Páral 2013-06-13 07:55:53 EDT
I confirmed that "scp://" fails with the same error as "file://".
Comment 6 Kamil Páral 2013-06-13 08:12:03 EDT

*** This bug has been marked as a duplicate of bug 971117 ***

Note You need to log in before you can comment on or make changes to this bug.