Bug 1000051 - Support only vfio-based device assignment
Support only vfio-based device assignment
Status: CLOSED DUPLICATE of bug 1025880
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Williamson
Virtualization Bugs
:
Depends On: 1000056 1025880
Blocks: 720747
  Show dependency treegraph
 
Reported: 2013-08-22 10:53 EDT by Alex Williamson
Modified: 2013-12-04 11:26 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-04 11:26:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Williamson 2013-08-22 10:53:23 EDT
Description of problem:
legacy KVM device assignment is deprecated.  Support only vfio-based device assignment going forward.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Ademar Reis 2013-11-05 16:47:02 EST
I got this from Markus: "As far as I know, the plan is to disable legacy KVM device in the *kernel*, and then close this bug without patching qemu-kvm."

Alex: is that your understanding as well?
Comment 3 Alex Williamson 2013-11-05 17:10:04 EST
(In reply to Ademar de Souza Reis Jr. from comment #2)
> I got this from Markus: "As far as I know, the plan is to disable legacy KVM
> device in the *kernel*, and then close this bug without patching qemu-kvm."
> 
> Alex: is that your understanding as well?

Yes, pci-assign should fail gracefully in qemu when it's disabled in the kernel.  libvirt should also favor vfio when configuring a guest, so the only way a user would be exposed to it is to manually configure their guest xml for pci-assign.  We would only need to patch qemu if exposing the pci-assign driver but not having it work is somehow unacceptable.
Comment 4 Alex Williamson 2013-12-04 11:26:26 EST

*** This bug has been marked as a duplicate of bug 1025880 ***

Note You need to log in before you can comment on or make changes to this bug.