Bug 720747 - [Tracker] ship only the RHEL7 features in qemu-kvm that we plan to support
[Tracker] ship only the RHEL7 features in qemu-kvm that we plan to support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: beta
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
: Tracking
: 895240 (view as bug list)
Depends On: 760885 760894 787463 816603 879890 880485 889051 889670 903910 903914 903918 903922 915399 917555 921971 921974 921983 947441 966024 976476 994642 1000051 1001076 1001088 1001113 1001123 1001131 1001144 1001180 1001216 1001222 1002286 1010858 1025880 1026966 1031098 1039214
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-12 12:29 EDT by Markus Armbruster
Modified: 2014-08-11 09:37 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-11 09:37:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Armbruster 2011-07-12 12:29:40 EDT
Description of problem:
QEMU is a large, complex program with many features.  Not all of them are sufficiently useful to customers to justify their support cost. To avoid "you shipped it, you support it" SNAFUs, we must choose the features to ship carefully.

My shot-from-the-hip take on what needs to be done:

1. Identify what exactly to support.

2. Compile out as much of the unsupported stuff as possible.  This may require significant upstream work to improve modularity and compile-time configurability.  Any leftovers will either require non-upstream patches (bad), or "this is not supported" user documentation (worse).

3. Tests to verify the unwanted stuff is gone.

This is almost certainly too much for a single person.  Whoever gets assigned this bug should coordinate a team effort.
Comment 2 Karen Noel 2012-04-29 11:29:01 EDT
Changed the title to be more specific, amidst the rest of the BZs.

Consulted Avi:

> More like an unfeature request. I'm in favour.

> It will take some effort to discover exactly
what's in qemu and what we can safely disable.  We can then evaluate
customer requests to re-enable stuff that we've disabled, in case they
need it.
Comment 5 Paolo Bonzini 2013-03-04 12:29:22 EST
*** Bug 895240 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.