Bug 1000224 - [ALL_LANG][Admin Portal] Unlocalized string 'Role ... on User ...' in 'Remove Permission' dialog.
[ALL_LANG][Admin Portal] Unlocalized string 'Role ... on User ...' in 'Remove...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Linux
medium Severity medium
: ---
: 3.3.0
Assigned To: Alexander Wels
Yuko Katabami
ux
: CodeChange, i18n, Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 22:42 EDT by Lijun Li
Modified: 2014-01-21 17:26 EST (History)
9 users (show)

See Also:
Fixed In Version: is15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unlocalized string 'Role ... on User ...' in 'Remove Permission' dialog (23.71 KB, image/png)
2013-08-22 22:44 EDT, Lijun Li
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18936 None None None Never

  None (edit)
Description Lijun Li 2013-08-22 22:42:54 EDT
Description of problem:
Unlocalized string 'Role ... on User ...' in 'Remove Permission' dialog.

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.16.master.el6ev.noarch.rpm
rhevm-webadmin-portal-3.3.0-0.16.master.el6ev.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1. Login web admin portal.
2. Click on Data Centers -> Permissions sub-tab.
3. Add a permission and then click Remove.

Actual results:
Unlocalized string 'Role ... on User ...' in 'Remove Permission' dialog.

Expected results:
Words 'Role ... on User ...' should be localized.

Additional info:
Please refer to the attached screen shot for more details.
Comment 1 Lijun Li 2013-08-22 22:44:13 EDT
Created attachment 789433 [details]
Unlocalized string 'Role ... on User ...' in 'Remove Permission' dialog
Comment 2 Einav Cohen 2013-09-05 17:05:11 EDT
I would like to believe that this one will be solved along with Bug 1001410, but  keeping this one opened since the reproducible scenario is a bit different ('remove permissions' vs. 'remove system permissions').
Comment 3 Alexander Wels 2013-09-06 08:48:39 EDT
I actually noticed this while working on bug 1001410, and did fix it as part of that fix. I will be pushing up the patch soon.
Comment 4 Alexander Wels 2013-09-06 14:15:09 EDT
There are a large number of places that users can have a role assigned to them. I fixed and i18ned the following main tabs:
webadmin:
* Cluster
* Datacenter
* Disks
* Hosts
* Networks
* Pools
* Quota
* Storage
* Template
* Users
* VMs
* VnicProfile
* Volume
userportal:
* VMs
* Templates.
Comment 6 Satyabrata Maitra 2013-09-27 02:00:12 EDT
Created attachment 803737 [details]
Unlocalized Role and User still persists. Example-2
Comment 7 Einav Cohen 2013-10-01 09:45:27 EDT
This BZ is actually a CodeChange (updated Keywords accordingly), I am moving it to VERIFIED, as the code-change is in.

The originally reported issue should be verified in the context of the i18n BZ (bug 1013599), once it will move to ON_QA.
Comment 8 Itamar Heim 2014-01-21 17:21:25 EST
Closing - RHEV 3.3 Released
Comment 9 Itamar Heim 2014-01-21 17:26:48 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.