Bug 1000534 - User Guide - Bugs in version 3.2
User Guide - Bugs in version 3.2
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: Publican Users Guide (Show other bugs)
future
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Ruediger Landmann
tools-bugs
:
: 1031300 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 11:11 EDT by Norman Dunbar
Modified: 2013-12-18 21:46 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 21:46:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Open Suse Installation chapter (11.57 KB, application/docbook+xml)
2013-08-23 11:11 EDT, Norman Dunbar
no flags Details
Corrected websites.xml source file (13.40 KB, application/xml)
2013-08-23 11:13 EDT, Norman Dunbar
no flags Details

  None (edit)
Description Norman Dunbar 2013-08-23 11:11:59 EDT
Created attachment 789619 [details]
Open Suse Installation chapter

Description of problem:
A number of bugs exists in the Publican User Guide for Publican 3.2.0.


Version-Release number of selected component (if applicable):
3.2.0

How reproducible:
Always.

Steps to Reproduce:
1. N/A
2.
3.

Actual results:
User Guide with bugs.

Expected results:
User Guide without bugs! ;-)

Additional info:

Section 1.1.5 OpenSuse 12 - Step 8 Install Publican. The current text is wrong as it should be "sudo sh ./Build install" as opposed to "sudo sh ./Build test". However, this is a bug I created! (Installing_Publican_OpenSuse.xml)

FIXED - see attached file.


Chapter 7 - Building a Website. Page 77 (On A4 paper) the description of the various files created in a website includes "defualt.js" which is incorrectly spelt and should be "default.js". (Websites.xml)

FIXED - see attached file.


Section 7.3.1 Submitting Your Sitemap to Google - Step 11 has no content. It also is overwritten by the word "Result". (Websites.xml)

CANNOT FIX. Rendering problem.


Section 7.3.2 Submitting Your Sitemap to Bing - Step 11 has no content. It also is overwritten by the word "Result". (Websites.xml)

CANNOT FIX. Rendering problem.


Chapter 8 - Drupal. All the screen shots are wider than the permitted 444 pixels and as such, are truncated on the right side of a rendered PDF file. (images/drupal*)

CANNOT FIX - Images don';t scale very well to 444.


Page 99 (on A4 paper), the page before section 8.3.4 How to Update Book in the Drupal chapter, is what appears to be a rogue "OpenShift" page that appears to be included in the Users Guide for no purpose. Should it be there? It seems to be unrelated to the example document uploaded into Drupal in the preceeding pages. (Drupal_Import.xml)

CANNOT FIX.


Chapter 9 - FAQ. What happened to Spell Check FAQ has an example Bash script. The code in the line defining ASPELL_EXCLUDES wanders off the right side of a PDF rendered page. (Even with wrap mode turned on in pdf.xsl!) (FAQ.xml)

CANNOT FIX - Rendering problem.


Appendix F - Sample Spec for desktop menu package. The code near the bottom of the page is extended off the right side of the page. The whole example file is formatted badly due to the wrap which is enabled in example.properties at line 97 of pdf.xml.

CANNOT FIX - Rendering problem.


Where I have indicated above FIXED, I have attached a source file with the corrections included to this bug report. Sadly, I can't fix the others.
Comment 1 Norman Dunbar 2013-08-23 11:13:06 EDT
Created attachment 789620 [details]
Corrected websites.xml source file
Comment 3 HSS Product Manager 2013-09-23 02:47:39 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 4 Ruediger Landmann 2013-11-14 01:37:23 EST
Thanks for your help Norman!

I've:

* incorporated the fixes you supplied
* re-structured the "submit your sitemap" procedures for greater clarity
* trimmed down the Drupal images as much as possible and removed the superfluous book cover image

The examples where code wanders off the page aren't presenting to me when I build with wkhtmltopdf, so I'm assuming these are FOP issues? This wasn't a problem for us with FOP (0.95) either: http://jfearn.fedorapeople.org/en-US/Publican/2.8/pdf/Users_Guide/Publican-2.8-Users_Guide-en-US.pdf so I'm not sure there's anything we can do to help with that... :(

204eb8d..d1e320c  devel -> devel
d1e320c..b5a8407  devel -> devel
Comment 5 Ruediger Landmann 2013-11-17 18:15:30 EST
*** Bug 1031300 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.