Bug 1000692 - mistranslation in libreoffice-langpack-de if opening Format->Absatz
mistranslation in libreoffice-langpack-de if opening Format->Absatz
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-24 06:29 EDT by Joachim Backes
Modified: 2013-08-28 06:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 06:34:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2013-08-24 06:29:16 EDT
Description of problem:
If opening Format->Absatz (english: Format->paragraph), then I see in the Absatz section 2 entries: "Über Absatz" and "Unter Absatz" with two input fields: "0,0Line". (In original english, it's "0.00line"). If understand this correctly, then in the German version, it should be "0,0Zeile(n)" (the word "Linie" leads me to some misunderstanding, because I don't understand what's
meant!).

Version-Release number of selected component (if applicable):
libreoffice-langpack-de-4.1.1.2-1.fc19.x86_64
libreoffice-4.1.1.2-1.fc19.x86_64

Older LO shows: "0,0cm" instead of "0,0Linie"

Additionally: It would be nice if I could get back this old behaviour (cm unit instead of "Linie/Line" unit?

How reproducible:

always
Steps to Reproduce:
1.Set the desktop lang to German
2.Format->Absatz
3.

Actual results:
"Über Absatz: 0,0Linie"

Expected results:
"Über Absatz: 0,0Zeile" ot the old behaviour (cm instead of Linie)

Additional info:
Comment 1 Joachim Backes 2013-08-26 10:46:07 EDT
Seems to be my problem: By setting tools->options->writer->general->"enable
character unit" to off I got the old behaviour (See BZ 1000234, similar problem)
Comment 2 Joachim Backes 2013-08-28 00:27:43 EDT
I have to reopen and refine the description:

I'm using libreoffice-langpack-de.

The following happens if tools->options->writer->general->"enable
character unit" is on:

If opening the menu Format->Absatz (english: Format->paragraph), then I see in the Absatz section 2 entries: "Über Absatz" and "Unter Absatz" with two input fields: "0,0Line". (In original english, it's "0.00line"). If understand this correctly, then in the German version it should be "0,0Zeile(n)" (the word "Linie" does not show the real facts!)
Comment 3 Caolan McNamara 2013-08-28 06:34:16 EDT
Fixed this upstream now as http://cgit.freedesktop.org/libreoffice/translations/commit/?id=567bb9410fe82204fd990f2ef92fe530a7ef45bc

Its a fairly obscure feature for the non-CJK users so it can wait until the next release I reckon

Note You need to log in before you can comment on or make changes to this bug.