Bug 1000703 - TypeError: not enough arguments for format string
TypeError: not enough arguments for format string
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
abrt_hash:5a733eafaef568ba26dcb7b9141...
: Reopened
: 1000930 (view as bug list)
Depends On:
Blocks: F20AlphaFreezeException F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-08-24 08:22 EDT by Joachim Frieben
Modified: 2013-09-09 22:19 EDT (History)
22 users (show)

See Also:
Fixed In Version: anaconda-20.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 09:47:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (410.40 KB, text/plain)
2013-08-24 08:22 EDT, Joachim Frieben
no flags Details
File: anaconda.log (9.89 KB, text/plain)
2013-08-24 08:22 EDT, Joachim Frieben
no flags Details
File: environ (517 bytes, text/plain)
2013-08-24 08:22 EDT, Joachim Frieben
no flags Details
File: lsblk_output (2.24 KB, text/plain)
2013-08-24 08:22 EDT, Joachim Frieben
no flags Details
File: nmcli_dev_list (480 bytes, text/plain)
2013-08-24 08:22 EDT, Joachim Frieben
no flags Details
File: os_info (281 bytes, text/plain)
2013-08-24 08:22 EDT, Joachim Frieben
no flags Details
File: program.log (45.00 KB, text/plain)
2013-08-24 08:22 EDT, Joachim Frieben
no flags Details
File: storage.log (208.53 KB, text/plain)
2013-08-24 08:22 EDT, Joachim Frieben
no flags Details
File: ifcfg.log (1.47 KB, text/plain)
2013-08-24 08:22 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2013-08-24 08:22:07 EDT
Description of problem:
Select custom partititioning and proceed.

Version-Release number of selected component:
anaconda-20.8-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.8-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 959, in _do_refresh
    self._whenCreateLabel.set_text(self._when_create_text % {"name" : productName, "version" : productVersion})
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 882, in refresh
    self._do_refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 108, in _runSpoke
    action.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 413, in _on_spoke_clicked
    self._runSpoke(spoke)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 429, in _on_spoke_clicked
    self._on_spoke_clicked(self._spokes[dest].selector, None, self._spokes[dest])
TypeError: not enough arguments for format string

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-20-Nightly-x86_64-Live-de rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git2.1.fc20.x86_64
product:        Fedora
release:        Fedora release 20 (Null)
type:           anaconda
version:        20
Comment 1 Joachim Frieben 2013-08-24 08:22:17 EDT
Created attachment 789839 [details]
File: anaconda-tb
Comment 2 Joachim Frieben 2013-08-24 08:22:22 EDT
Created attachment 789840 [details]
File: anaconda.log
Comment 3 Joachim Frieben 2013-08-24 08:22:26 EDT
Created attachment 789841 [details]
File: environ
Comment 4 Joachim Frieben 2013-08-24 08:22:31 EDT
Created attachment 789842 [details]
File: lsblk_output
Comment 5 Joachim Frieben 2013-08-24 08:22:35 EDT
Created attachment 789843 [details]
File: nmcli_dev_list
Comment 6 Joachim Frieben 2013-08-24 08:22:39 EDT
Created attachment 789844 [details]
File: os_info
Comment 7 Joachim Frieben 2013-08-24 08:22:44 EDT
Created attachment 789845 [details]
File: program.log
Comment 8 Joachim Frieben 2013-08-24 08:22:51 EDT
Created attachment 789846 [details]
File: storage.log
Comment 9 Joachim Frieben 2013-08-24 08:22:55 EDT
Created attachment 789847 [details]
File: ifcfg.log
Comment 10 Clyde E. Kunkel 2013-08-24 11:59:55 EDT
Selected single gpt disk and btrfs custom paritioning.  After clicking "Done" anaconda seemed go freeze with only the Quit button on input spokes screen active and begin installation button greyed out.  Then this error.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-20-Nightly-x86_64-Live-de rootfstype=auto ro rd.live.image enforcing=0 rd.auto=1 rd.luks=0 rd.md=1 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git2.1.fc20.x86_64
package:        anaconda-20.8-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         TypeError: not enough arguments for format string
release:        Fedora release 20 (Null)
version:        20
Comment 11 Mark E. Wilt 2013-08-24 12:31:09 EDT
Running anaconda install of Fedora-20; get to the disk-partioning step & select "Standard Partitions" (v. LVM) & select ok/done; after several seconds, it pops up a failure screen allowing me to report a bug...here's the report.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.8-1
product:        Fedora
reason:         TypeError: not enough arguments for format string
release:        Cannot get release name.
version:        20
Comment 12 Christopher Patrick 2013-08-26 13:38:29 EDT
I went to install the fedora from the Fedora-20-Nightly-x86_64-Live-desktop-20130825.08-1.iso, got all the way to the disk partition screen and when I went selected custom partitioning it crashed on me.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-20-Nightly-x86_64-Live-de rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.8-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         TypeError: not enough arguments for format string
release:        Fedora release 20 (Null)
version:        20
Comment 13 Mukundan Ragavan 2013-08-26 16:38:26 EDT
I chose custom partitioning and anaconda went back to the hub.

Chose the partitioning spoke again and chose custom partitioning again. Anaconda crashed.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC1\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.8-1
product:        Fedora
reason:         TypeError: not enough arguments for format string
release:        Cannot get release name.
version:        20-Alpha-TC1
Comment 14 Mukundan Ragavan 2013-08-26 16:44:15 EDT
Unfortunately, I do not know what caused this crash.

I just navigated from the "installation source" spoke back to the hub.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC1\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.8-1
product:        Fedora
reason:         TypeError: not enough arguments for format string
release:        Cannot get release name.
version:        20-Alpha-TC1
Comment 15 A.J. Werkman 2013-08-27 14:34:07 EDT
Selecting partitioning for the second time, got this bug.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC1\x20x86_64 xdriver=vesa nomodeset quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.8-1
product:        Fedora
reason:         TypeError: not enough arguments for format string
release:        Cannot get release name.
version:        20-Alpha-TC1
Comment 16 Joachim Frieben 2013-08-27 15:02:18 EDT
Select custom partitioning and proceed.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-20-Nightly-x86_64-Live-de rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.9-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         TypeError: not enough arguments for format string
release:        Fedora release 20 (Null)
version:        20
Comment 17 David Shea 2013-08-28 10:06:18 EDT
*** Bug 1000930 has been marked as a duplicate of this bug. ***
Comment 18 lnie 2013-08-29 00:24:23 EDT
still occur in F20 Alpha TC2(netinst)
Comment 19 Mukundan Ragavan 2013-08-29 09:57:24 EDT
Seeing in TC2 as well.
Comment 20 stan 2013-08-29 15:39:12 EDT
Selected custom partitioning with standard partitions, using netinstall image.

Installer software check passed, then had error of couldn't mount install repo.

Second try, without check, got this error.

Want to use existing ext4 partitions as target for install.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC2\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         TypeError: not enough arguments for format string
release:        Cannot get release name.
version:        20-Alpha-TC2
Comment 21 spital 2013-08-30 04:38:21 EDT
install nightly under vmware player

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-20-Nightly-x86_64-Live-xf rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         TypeError: not enough arguments for format string
release:        Fedora release 20 (Null)
version:        20
Comment 22 Joachim Frieben 2013-09-01 12:34:54 EDT
Bugzilla says:

    ``You reported this bug, a change has been committed and you should
      verify the problem is fixed.''

and

    ``Fixed In Version: anaconda-20.10-1''

So, where is the update? It is not in koji ..
Comment 23 Simon A. Erat 2013-09-01 15:15:02 EDT
1. Started installer (anaconda)
2. Selected german interface
3. Selected target harddisk
4. Aborted to make screenshots of english gui to update a guide
--- from here on repeatable ---
5. Restarted anaconda
6. kept english/us as language
7. select disk
8. choose options - review setup *lowest* & plain partitions
9. -continue- (dont recall proper label/caption)
10. Error

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-LXDE-x86_64-20-Alpha rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         TypeError: not enough arguments for format string
release:        Fedora release 20 (Null)
version:        20
Comment 24 Martin Krizek 2013-09-02 05:35:55 EDT
Installing from live image:
1. Installation Destination
2. Selected disk
3. Selected that I wanted to review partitions and the traceback occured

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-x86_64-20-Alpha- rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         TypeError: not enough arguments for format string
release:        Fedora release 20 (Null)
version:        20
Comment 25 Richard Ryniker 2013-09-04 11:03:22 EDT
Boot F20 alpha TC2 from USB flash drive.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC2\x20x86_64 BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         TypeError: not enough arguments for format string
release:        Cannot get release name.
version:        20-Alpha-TC2
Comment 26 Kamil Páral 2013-09-04 12:19:28 EDT
Discussed at 2013-09-04 blocker review meeting [1]. This is reject as an Alpha blocker, because this doesn't violate any F20 alpha release critera and thus does not qualify as a release blocking bug. However, a tested fix would be considered past freeze.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-04/

Also re-proposing as Beta blocker.
Comment 27 lnie 2013-09-04 23:06:04 EDT
still occurs in TC3 (netinst).
Comment 28 Kamil Páral 2013-09-05 05:26:11 EDT
Christoph, what was the reason for closing this bug? We need it to track this bug in Fedora 20, not just Rawhide. Please provide some details when closing bugs, thanks. Reopening per comment 27.
Comment 29 Joachim Frieben 2013-09-07 03:06:14 EDT
Bug 1000703 was closed as of 2013-09-04 because anaconda-20.10-1 fixes this issue and has already been pushed to rawhide (in the meantime, it has been included into the stage TC4 images and allow one to go beyond the step ``custom partitioning'' even without updating anaconda of the running live system prior to install).
Comment 30 Kamil Páral 2013-09-09 04:11:51 EDT
OK, we need to make sure anaconda is pushed to Fedora 20 stable before we close this. anaconda-20.10 is now in stable. Christoph, are you saying you have verified this bug with F20 Alpha TC4 and it is resolved? Lili, can you please verify too, ideally with TC5? Thanks.
Comment 31 Mukundan Ragavan 2013-09-09 09:18:04 EDT
It is fixed in TC5 for sure. I am not seeing this anymore.
Comment 32 Richard Ryniker 2013-09-09 09:38:58 EDT
It is fixed in TC4... I installed using the custom partition path without problems.
Comment 33 Kamil Páral 2013-09-09 09:47:34 EDT
Thanks, closing.
Comment 34 lnie 2013-09-09 22:19:09 EDT
Kamil,it is fixed.:)

Note You need to log in before you can comment on or make changes to this bug.