Bug 1000713 - nscd %post were not expanded
nscd %post were not expanded
Status: CLOSED DUPLICATE of bug 999924
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlos O'Donell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-24 09:53 EDT by Michael Scherer
Modified: 2016-11-24 10:50 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-25 22:17:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Scherer 2013-08-24 09:53:11 EDT
~ $ rpm -q --scripts  nscd
preinstall scriptlet (using /bin/sh):
getent group nscd >/dev/null || /usr/sbin/groupadd -g 28 -r nscd
getent passwd nscd >/dev/null ||
  /usr/sbin/useradd -M -o -r -d / -s /sbin/nologin \
		    -c "NSCD Daemon" -u 28 -g nscd nscd
postinstall scriptlet (using /bin/sh):
%systemd_post nscd.service
preuninstall scriptlet (using /bin/sh):
%systemd_preun nscd.service
postuninstall scriptlet (using /bin/sh):
if test $1 = 0; then
  /usr/sbin/userdel nscd > /dev/null 2>&1 || :
fi
%systemd_postun_with_restart nscd.service


$ rpm -q  nscd          
nscd-2.17-13.fc19.x86_64

this make the package unable to be upgraded, without manually fiddling with it.
Comment 1 Siddhesh Poyarekar 2013-08-25 22:17:33 EDT

*** This bug has been marked as a duplicate of bug 999924 ***

Note You need to log in before you can comment on or make changes to this bug.