Bug 1000810 - It's impossible to start VM (or hotplug) when VNIC profile on the VM has QOS configured only on Inbound or only on Outbound
It's impossible to start VM (or hotplug) when VNIC profile on the VM has QOS ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
high Severity unspecified
: ---
: 3.3.0
Assigned To: Moti Asayag
GenadiC
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-25 10:37 EDT by GenadiC
Modified: 2016-02-10 14:58 EST (History)
6 users (show)

See Also:
Fixed In Version: is13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (895.34 KB, text/x-log)
2013-08-25 10:37 EDT, GenadiC
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18676 None None None Never

  None (edit)
Description GenadiC 2013-08-25 10:37:02 EDT
Created attachment 790095 [details]
engine log

Description of problem:
If you create VNIC profile with QOS inbound or QOS outbound only (leave one direction unchanged during creation) then it will be impossible to start VM with such a profile attached


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create new Network QOS while making only Inbound configuration
2. Attach this Network QOS to profile
3. Add this profile to VM and try to start VM or try to hotplug

Actual results:
Start will fail with Internal Engine error

Expected results:
Start VM (or hotplug) should succeed

Additional info:
013-08-25 17:27:26,021 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.HotPlugNicVDSCommand] (ajp-/127.0.0.1:8702-9) Failed in HotPlugNicVDS method, for vds: silver-vdsa.qa.lab.tlv.redhat.com; host: 10.35.128.10
2013-08-25 17:27:26,021 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.HotPlugNicVDSCommand] (ajp-/127.0.0.1:8702-9) Command HotPlugNicVDS execution failed. Exception: NullPointerException: 
2013-08-25 17:27:26,021 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.HotPlugNicVDSCommand] (ajp-/127.0.0.1:8702-9) FINISH, HotPlugNicVDSCommand, log id: 649ab21a
2013-08-25 17:27:26,021 ERROR [org.ovirt.engine.core.bll.network.vm.ActivateDeactivateVmNicCommand] (ajp-/127.0.0.1:8702-9) Command org.ovirt.engine.core.bll.network.vm.ActivateDeactivateVmNicCommand throw Vdc Bll exception. With error message VdcBLLException: java.lang.NullPointerException (Failed with error ENGINE and code 5001)
Comment 1 Lior Vernia 2013-09-02 04:54:54 EDT
*** Bug 1003247 has been marked as a duplicate of this bug. ***
Comment 2 GenadiC 2013-09-04 03:33:42 EDT
Verified in IS13
Comment 3 Itamar Heim 2014-01-21 17:26:18 EST
Closing - RHEV 3.3 Released
Comment 4 Itamar Heim 2014-01-21 17:29:44 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.