Bug 1003247 - It's impossible to run VM with VNIC profile having unlimited Network QOS bandwidth
It's impossible to run VM with VNIC profile having unlimited Network QOS band...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
urgent Severity high
: ---
: 3.3.0
Assigned To: Lior Vernia
GenadiC
network
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-01 05:43 EDT by GenadiC
Modified: 2016-02-10 14:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:18:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (2.22 MB, text/x-log)
2013-09-01 05:43 EDT, GenadiC
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18676 None None None Never

  None (edit)
Description GenadiC 2013-09-01 05:43:17 EDT
Created attachment 792560 [details]
engine log

Description of problem:
If you create Network QOS with unlimited bandwidth and attach it to VNIC profile on the VM, then this VM will not run. Fails will Null pointer exception

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create Network QOS with unlimited Inbound and Outbound bandwidth
2. Attach it to VM
3. Try to run VM

Actual results:
Starting VM fails with NullPointerException

Expected results:
Running VM should work

Additional info:
2013-09-01 12:22:58,084 ERROR [org.ovirt.engine.core.vdsbroker.CreateVmVDSCommand] (pool-5-thread-48) [185f0b81] Command CreateVmVDS execution failed. Exception: RuntimeException: java.lang.NullPointerException
2013-09-01 12:22:58,084 INFO  [org.ovirt.engine.core.vdsbroker.CreateVmVDSCommand] (pool-5-thread-48) [185f0b81] FINISH, CreateVmVDSCommand, log id: 1eb1d5f5
2013-09-01 12:22:58,084 WARN  [org.ovirt.engine.core.bll.RunVmCommand] (pool-5-thread-48) [185f0b81] Failed to run VM VM_From_Temp_1: VdcBLLException: java.lang.RuntimeException: java.lang.NullPointerException (Fail
ed with error ENGINE and code 5001)
2013-09-01 12:22:58,084 INFO  [org.ovirt.engine.core.bll.RunVmCommand] (pool-5-thread-48) [185f0b81] Lock freed to object EngineLock [exclusiveLocks= key: 9419b335-c933-4379-bcde-d8e3c0071637 value: VM
, sharedLocks= ]
Comment 1 Lior Vernia 2013-09-02 04:54:54 EDT
Same cause as said bug, checked and saw that the fix for that fixes this as well.

*** This bug has been marked as a duplicate of bug 1000810 ***
Comment 2 Lior Vernia 2013-09-02 08:29:06 EDT
Apparently not a duplicate, I misread the description, just same fix.
Comment 3 GenadiC 2013-09-04 05:22:30 EDT
Verified in IS13
Comment 4 Itamar Heim 2014-01-21 17:18:53 EST
Closing - RHEV 3.3 Released
Comment 5 Itamar Heim 2014-01-21 17:25:09 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.