Bug 1000966 - [abrt] pulseaudio-4.0-3.gitbf9b3.fc20: report_jack_state: Process /usr/bin/pulseaudio was killed by signal 6 (SIGABRT)
[abrt] pulseaudio-4.0-3.gitbf9b3.fc20: report_jack_state: Process /usr/bin/pu...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
abrt_hash:47e44b22ea2bcd3ce88a9588d46...
:
: 999167 1015616 (view as bug list)
Depends On:
Blocks: F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-08-26 04:39 EDT by Jan Sedlák
Modified: 2014-09-13 14:58 EDT (History)
11 users (show)

See Also:
Fixed In Version: pulseaudio-4.0-4.gita89ca.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-26 20:40:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (13.18 KB, text/plain)
2013-08-26 04:39 EDT, Jan Sedlák
no flags Details
File: cgroup (159 bytes, text/plain)
2013-08-26 04:39 EDT, Jan Sedlák
no flags Details
File: core_backtrace (4.70 KB, text/plain)
2013-08-26 04:39 EDT, Jan Sedlák
no flags Details
File: dso_list (5.10 KB, text/plain)
2013-08-26 04:39 EDT, Jan Sedlák
no flags Details
File: environ (1016 bytes, text/plain)
2013-08-26 04:39 EDT, Jan Sedlák
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-26 04:39 EDT, Jan Sedlák
no flags Details
File: maps (24.52 KB, text/plain)
2013-08-26 04:39 EDT, Jan Sedlák
no flags Details
File: open_fds (1.07 KB, text/plain)
2013-08-26 04:39 EDT, Jan Sedlák
no flags Details
File: proc_pid_status (1.05 KB, text/plain)
2013-08-26 04:40 EDT, Jan Sedlák
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 69676 None None None Never

  None (edit)
Description Jan Sedlák 2013-08-26 04:39:30 EDT
Description of problem:
Booted into F20-Alpha TC1 and this error showed up.

Version-Release number of selected component:
pulseaudio-4.0-3.gitbf9b3.fc20

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/bin/pulseaudio --start
crash_function: report_jack_state
executable:     /usr/bin/pulseaudio
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 report_jack_state at modules/alsa/module-alsa-card.c:378
 #3 init_jacks at modules/alsa/module-alsa-card.c:510
 #4 module_alsa_card_LTX_pa__init at modules/alsa/module-alsa-card.c:752
 #5 pa_module_load at pulsecore/module.c:119
 #6 verify_access at modules/module-udev-detect.c:341
 #7 process_path at modules/module-udev-detect.c:489
 #8 module_udev_detect_LTX_pa__init at modules/module-udev-detect.c:797
 #9 pa_module_load at pulsecore/module.c:119
 #10 pa_cli_command_load at pulsecore/cli-command.c:441
 #11 pa_cli_command_execute_line_stateful at pulsecore/cli-command.c:2169

Potential duplicate: bug 999167
Comment 1 Jan Sedlák 2013-08-26 04:39:34 EDT
Created attachment 790337 [details]
File: backtrace
Comment 2 Jan Sedlák 2013-08-26 04:39:38 EDT
Created attachment 790338 [details]
File: cgroup
Comment 3 Jan Sedlák 2013-08-26 04:39:42 EDT
Created attachment 790339 [details]
File: core_backtrace
Comment 4 Jan Sedlák 2013-08-26 04:39:45 EDT
Created attachment 790340 [details]
File: dso_list
Comment 5 Jan Sedlák 2013-08-26 04:39:48 EDT
Created attachment 790341 [details]
File: environ
Comment 6 Jan Sedlák 2013-08-26 04:39:52 EDT
Created attachment 790342 [details]
File: limits
Comment 7 Jan Sedlák 2013-08-26 04:39:56 EDT
Created attachment 790343 [details]
File: maps
Comment 8 Jan Sedlák 2013-08-26 04:39:59 EDT
Created attachment 790344 [details]
File: open_fds
Comment 9 Jan Sedlák 2013-08-26 04:40:03 EDT
Created attachment 790345 [details]
File: proc_pid_status
Comment 10 Martin 2013-09-05 13:20:11 EDT
still reproducible after boot with TC4
Comment 11 Adam Williamson 2013-09-18 21:25:08 EDT
*** Bug 999167 has been marked as a duplicate of this bug. ***
Comment 12 Adam Williamson 2013-09-18 21:27:37 EDT
As per 999167, this is nominated as a final blocker under https://fedoraproject.org/wiki/Fedora_20_Final_Release_Criteria#SELinux_and_crash_notifications : "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop. "
Comment 13 Kalev Lember 2013-09-22 10:12:52 EDT
I've filed an upstream ticket for this:

https://bugs.freedesktop.org/show_bug.cgi?id=69676
Comment 14 Fedora Update System 2013-09-23 16:38:56 EDT
pulseaudio-4.0-4.gita89ca.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pulseaudio-4.0-4.gita89ca.fc20
Comment 15 Kalev Lember 2013-09-23 16:46:09 EDT
I've built a new package that should hopefully fix the crash; would be great if someone who was affected could test it.
Comment 16 Patrick Frost 2013-09-24 11:13:12 EDT
1) Installed Fedora20 Alpha release as VM on my Fedora19 laptop
2) Logged in

reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/bin/pulseaudio --start --log-target=syslog
crash_function: report_jack_state
executable:     /usr/bin/pulseaudio
kernel:         3.11.0-300.fc20.x86_64
package:        pulseaudio-4.0-3.gitbf9b3.fc20
reason:         Process /usr/bin/pulseaudio was killed by signal 6 (SIGABRT)
runlevel:       unknown
type:           CCpp
uid:            1000
Comment 17 Fedora Update System 2013-09-24 19:06:18 EDT
Package pulseaudio-4.0-4.gita89ca.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pulseaudio-4.0-4.gita89ca.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17580/pulseaudio-4.0-4.gita89ca.fc20
then log in and leave karma (feedback).
Comment 18 Adam Williamson 2013-09-25 02:56:07 EDT
Looks good, I built it into an F20 live, booted in a test VM, no crash. Will add feedback.
Comment 19 Fedora Update System 2013-09-26 20:40:56 EDT
pulseaudio-4.0-4.gita89ca.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Rex Dieter 2013-10-04 11:48:31 EDT
*** Bug 1015616 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.