This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1001100 - Add log gathering for a new ovirt module (External scheduler)
Add log gathering for a new ovirt module (External scheduler)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sos (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Sandro Bonazzola
Fedora Extras Quality Assurance
integration
: Improvement, Patch
Depends On:
Blocks: 902971 1073943 1073944
  Show dependency treegraph
 
Reported: 2013-08-26 09:49 EDT by Noam Slomianko
Modified: 2014-10-22 04:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Add log gathering for a new ovirt module (External scheduler) Reason: Result (if any):
Story Points: ---
Clone Of:
: 1073944 (view as bug list)
Environment:
Last Closed: 2014-10-22 04:08:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
global ovirt-engine plugin (proposed, not merged yet, upstream) (6.20 KB, patch)
2014-03-24 11:50 EDT, Sandro Bonazzola
no flags Details | Diff
ovirt-scheduler-proxy addition to global ovirt patch (2.50 KB, patch)
2014-03-24 11:51 EDT, Sandro Bonazzola
no flags Details | Diff

  None (edit)
Description Noam Slomianko 2013-08-26 09:49:33 EDT
Description of problem:
    A new service named external-scheduler-proxy will be added to ovirt.
    the log of the component needs to be gathered by sos

Log location:
    /var/log/ovirt-scheduler-proxy/
Comment 1 Bryn M. Reeves 2013-08-27 07:00:03 EDT
sos does not currently have any ovirt support.

Looking at the ovirt-log-collector project on github it appears that it ships its own sos plug-ins - this is something we very strongly discourage at the moment and we've been through a process to get these plug-ins removed from RHEV and upstream in sosreport.

Please work with sos upstream to include whatever plug-ins are required for sos to support the ovirt pieces. The project pages may be found here:

  https://github.com/sosreport/
Comment 3 Sandro Bonazzola 2014-03-07 10:02:24 EST
Martin, do you need anything else collected? Any configuration file? Or only the logs?
Comment 4 Martin Sivák 2014-03-24 11:12:50 EDT
Just the logs from /var/log/ovirt-scheduler-proxy/* and rpm version (ovirt-scheduler-proxy).
Comment 5 Sandro Bonazzola 2014-03-24 11:50:56 EDT
Created attachment 878109 [details]
global ovirt-engine plugin (proposed, not merged yet, upstream)
Comment 6 Sandro Bonazzola 2014-03-24 11:51:50 EDT
Created attachment 878110 [details]
ovirt-scheduler-proxy addition to global ovirt patch
Comment 7 Fedora Update System 2014-06-18 06:25:05 EDT
sos-3.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sos-3.1-1.fc19
Comment 8 Fedora Update System 2014-06-26 22:25:49 EDT
sos-3.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Sandro Bonazzola 2014-10-22 04:08:52 EDT
Moving to closed, current release since it's in stable.

Note You need to log in before you can comment on or make changes to this bug.