Bug 1001154 - [abrt] yum-3.4.3-106.fc19: cli.py:482:waitForLock:YumBaseError: No se puede crear archivo de bloqueo, ya existe uno
[abrt] yum-3.4.3-106.fc19: cli.py:482:waitForLock:YumBaseError: No se puede c...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:b117c79506f3cd59bc682b7ac62...
:
: 1019381 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 10:52 EDT by wared-red
Modified: 2014-05-28 09:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-28 09:00:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (823 bytes, text/plain)
2013-08-26 10:52 EDT, wared-red
no flags Details
File: environ (1.49 KB, text/plain)
2013-08-26 10:53 EDT, wared-red
no flags Details

  None (edit)
Description wared-red 2013-08-26 10:52:50 EDT
Version-Release number of selected component:
yum-3.4.3-106.fc19

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python /usr/bin/yum --enablerepo=* clean all
executable:     /usr/bin/yum
kernel:         3.10.9-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
cli.py:482:waitForLock:YumBaseError: No se puede crear archivo de bloqueo, ya existe uno

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 316, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 123, in main
    base.waitForLock()
  File "/usr/share/yum-cli/cli.py", line 482, in waitForLock
    raise yum.Errors.YumBaseError, _("Can't create lock file; exiting")
YumBaseError: No se puede crear archivo de bloqueo, ya existe uno

Local variables in innermost frame:
lockerr: u'No se ha podido crear el bloqueo en /var/tmp/yum-w4r3d-1m0jgj/x86_64/19/yum.pid: [Errno 28] No queda espacio en el dispositivo'
self: <cli.YumBaseCli object at 0x2233ed0>
e: LockError()
Comment 1 wared-red 2013-08-26 10:52:54 EDT
Created attachment 790554 [details]
File: backtrace
Comment 2 wared-red 2013-08-26 10:53:02 EDT
Created attachment 790555 [details]
File: environ
Comment 3 Zdeněk Pavlas 2013-08-26 11:14:16 EDT
There was a bug in commit 8c214b3b that moved the waitForLock() function, it does not handle failures as it should.  This includes wait_for_lock=True case, too.  Fixed upstream.
Comment 4 Zdeněk Pavlas 2013-10-16 04:14:38 EDT
*** Bug 1019381 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.