Bug 1001222 - Disable or remove miscellaneous useless devices
Disable or remove miscellaneous useless devices
Status: CLOSED DUPLICATE of bug 1001216
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
Depends On: 1001216
Blocks: 720747
  Show dependency treegraph
 
Reported: 2013-08-26 15:19 EDT by Markus Armbruster
Modified: 2013-11-14 03:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-14 03:08:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Armbruster 2013-08-26 15:19:32 EDT
Description of problem:
PIIX3-xen is an onboard device used with accel=xen.  We don't have that in RHEL-7.

isabus-bridge is an onboard device used with machine types that don't provide a PCI bus.  We don't have that in RHEL-7.

Neither should be available with -device.

How reproducible:
Always

Steps to Reproduce:
1. for X in the above devices: -device X

Actual results:
-device X is accepted

Expected results:
-device X is rejected, just like -device nonexistant
Comment 2 Markus Armbruster 2013-11-02 12:30:49 EDT
The patches I posted for bug 1001216 make these two devices unavailable with -device.
Comment 3 Markus Armbruster 2013-11-14 03:08:08 EST
Since the patch for bug 1001216 resolves this bug as well, I'm closing it as duplicate.

*** This bug has been marked as a duplicate of bug 1001216 ***

Note You need to log in before you can comment on or make changes to this bug.