Bug 1001361 - Ruby on Rails 4.0
Summary: Ruby on Rails 4.0
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: release-notes
Version: devel
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pete Travis
QA Contact: Fedora Docs QA
URL:
Whiteboard:
Keywords: Tracking
Depends On: 998578
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-26 23:05 UTC by Pete Travis
Modified: 2014-01-13 13:55 UTC (History)
6 users (show)

(edit)
Clone Of: 998578
(edit)
Last Closed: 2014-01-13 13:55:14 UTC


Attachments (Terms of Use)

Description Pete Travis 2013-08-26 23:05:02 UTC
+++ This bug was initially created as a clone of Bug #998578 +++

This is a tracking bug for Change: Ruby on Rails 4.0
For more details, see: http://fedoraproject.org//wiki/Changes/Ruby_on_Rails_4.0

Ruby on Rails 4.0 is the latest version of well know web framework written in Ruby.

Discussion at https://lists.fedoraproject.org/pipermail/devel-announce/2013-July/001189.html

Please create entries for this Change in the Release Notes.

Comment 1 Pete Travis 2013-10-06 04:53:19 UTC
draft posted to https://fedoraproject.org/wiki/Documentation_Development_Web_Beat

Comment 2 Vít Ondruch 2013-10-07 07:52:04 UTC
Hi Pete,

The "This latest release includes improved functionality, speed, and security in addition to better modularization." sentence looks more like Rails 3.0 description. Wouldn't be better to condensate the three bullets from [1] into one sentence instead (or in addition), something along the lines:

"This release highly improves caching through key-based expiration with automatic dependency management of nested templates, speeds-up the client-side essentially by turning your app into a single-page javascript application and benefits from the latest HTTP etag features."

[1] http://weblog.rubyonrails.org/2013/6/25/Rails-4-0-final/


Note You need to log in before you can comment on or make changes to this bug.