Bug 998578 - Ruby on Rails 4.0
Ruby on Rails 4.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Josef Stribny
: Tracking
Depends On:
Blocks: 1001361 1001362
  Show dependency treegraph
 
Reported: 2013-08-19 10:26 EDT by Jaroslav Reznik
Modified: 2016-01-04 00:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1001361 1001362 (view as bug list)
Environment:
Last Closed: 2013-12-18 09:00:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2013-08-19 10:26:33 EDT
This is a tracking bug for Change: Ruby on Rails 4.0
For more details, see: http://fedoraproject.org//wiki/Changes/Ruby_on_Rails_4.0

Ruby on Rails 4.0 is the latest version of well know web framework written in Ruby.
Comment 1 Jaroslav Reznik 2013-10-11 04:46:50 EDT
This message is a reminder that Fedora 20 Accepted Changes 100%
Completed Deadline is on 2013-10-15 [1].

All Accepted Changes has to be code complete and ready to be
validated in the Beta release (optionally by Fedora QA). Required
bug state at this point is ON_QA.

As for several System Wide Changes, Beta Change Deadline is a
point of contingency plan, all incomplete Changes will be 
reported to FESCo for 2013-10-16 meeting. In case of any
questions, don't hesitate to ask Wrangler (jreznik).

[1] https://fedoraproject.org/wiki/Releases/20/Schedule
Comment 2 Josef Stribny 2013-10-11 06:22:00 EDT
The change is near to be 100%. Rails itself should install and run, but one default gem in the GEMFILE for generating docs - sdoc - is missing, because it doesn't support RDoc 4.0 yet.
Comment 3 Josef Stribny 2013-10-11 10:35:50 EDT
* To test the complete feature including generating a new Rails app using RPM (Note: sdoc is not yet in f20/rawhide):

```
$ su -c "yum install rubygem-{rails,sqlite3,coffee-rails,sass-rails,uglifier,jquery-rails,turbolinks,jbuilder,therubyracer}"
$ gem install sdoc
$ rails new app --skip-bundle && cd app
$ sed -i "s|# gem 'therubyracer'|gem 'therubyracer'|" Gemfile
$ rails s
```

* Check http://127.0.0.1:3000/ to make sure you are running Rails 4.0
Comment 4 Jaroslav Reznik 2013-10-21 09:37:08 EDT
(In reply to Josef Stribny from comment #2)
> The change is near to be 100%. Rails itself should install and run, but one
> default gem in the GEMFILE for generating docs - sdoc - is missing, because
> it doesn't support RDoc 4.0 yet.

Any ETA on the sdoc? Could be the Change considered as completed even without it? FESCo asked me to finish the review this week.
Comment 5 Josef Stribny 2013-10-23 08:56:03 EDT
I think so. Rails itself works and sdoc is only suggested gem for generating documentation for the projects build with it. ETA is probably one or two weeks.
Comment 6 Jaroslav Reznik 2013-10-23 08:57:54 EDT
Thank you, moving to ON_QA to mark Change is completed.
Comment 7 Jaroslav Reznik 2013-12-18 09:00:56 EST
Closing this bug as this Change was delivered in Fedora 20 release. Please, reopen in case of any issues you encounter regarding this Change completion.

Note You need to log in before you can comment on or make changes to this bug.