Bug 1001398 - Non-fatal POSTIN scriptlet failure
Non-fatal POSTIN scriptlet failure
Status: CLOSED DUPLICATE of bug 995158
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 20:53 EDT by Garry T. Williams
Modified: 2013-10-30 10:55 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 04:42:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garry T. Williams 2013-08-26 20:53:51 EDT
Description of problem:
yum update produced this message:

Updating   : acpid-2.0.19-5.fc19.x86_64                                 34/78 
/var/tmp/rpm-tmp.giNN7c: line 1: fg: no job control
warning: %post(acpid-2.0.19-5.fc19.x86_64) scriptlet failed, exit status 1
Non-fatal POSTIN scriptlet failure in rpm package acpid-2.0.19-5.fc19.x86_64
  Updating   : libvdpau-0.7-1.fc19.x86_64                                 35/78


Version-Release number of selected component (if applicable):
F19


How reproducible:


Steps to Reproduce:
1. yum update
2.
3.

Actual results:
Updating   : acpid-2.0.19-5.fc19.x86_64                                 34/78 
/var/tmp/rpm-tmp.giNN7c: line 1: fg: no job control
warning: %post(acpid-2.0.19-5.fc19.x86_64) scriptlet failed, exit status 1
Non-fatal POSTIN scriptlet failure in rpm package acpid-2.0.19-5.fc19.x86_64
  Updating   : libvdpau-0.7-1.fc19.x86_64                                 35/78


Expected results:
Updating   : acpid-2.0.19-5.fc19.x86_64                                 34/78
Updating   : libvdpau-0.7-1.fc19.x86_64                                 35/78


Additional info:
Comment 1 marianne@tuxette.fr 2013-08-27 07:31:51 EDT
after update, I have 2 versions of acpid on the system 

[root@cherrytree ~]# package-cleanup --dupes
Modules complémentaires chargés : langpacks, refresh-packagekit
acpid-2.0.19-6.fc19.x86_64
acpid-2.0.19-5.fc19.x86_64

I had to launch  rpm -e --noscripts acpid-2.0.19-5.fc19.x86_64 to remove the old one
Comment 2 Erwan David 2013-08-27 09:17:07 EDT
To me it looks similar to bug 980899,and indeed
rpm -e --noscripts acpid-2.0.19-5.fc19 corrects the situation.
Comment 3 Trevor Cordes 2013-09-19 14:13:41 EDT
This is an annoying bug.  I have a dozen F19 systems showing this problem (2 copies of acpid installed).

I also want to note the exact same thing is happening with nscd:

/var/tmp/rpm-tmp.lzDeXu: line 1: fg: no job control
error: %preun(nscd-2.17-13.fc19.i686) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package nscd-2.17-13.fc19.i686
  Cleanup    : lockdev-1.0.4-0.8.20111007git.fc19.i686                                                               254/345
error: nscd-2.17-13.fc19.i686: erase failed
/var/tmp/rpm-tmp.X3HpZE: line 1: fg: no job control
error: %preun(acpid-2.0.19-5.fc19.i686) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package acpid-2.0.19-5.fc19.i686

#rpm -q nscd
nscd-2.17-13.fc19.i686
nscd-2.17-14.fc19.i686


I don't know, is it even possible for an updated RPM to clean up twice-installed packages or are we all stuck manually uninstalling as per comment #2?  A lot of people will never notice the problem, but this could cause them headaches down the road?
Comment 4 Trevor Cordes 2013-09-19 14:20:24 EDT
As an aid, you can see what packages are messed up like this and installed twice on a system by running:

rpm --qf '%{NAME}\n' -qa |sort| uniq --repeated

On most systems this should only output: kernel* and gpg-pubkey.  Everything else is probably due to a bug like this one.
Comment 5 Johan Swensson 2013-10-29 16:24:03 EDT
Reassigning to acpid as this issue seems related to acpid and not acpi.
Comment 6 Jaroslav Škarvada 2013-10-30 04:42:45 EDT
This cannot be fixed. The problem is in already released package and there is no way how to automatically workaround it by update. The problem wasn't caused by the change in the acpid package itself, but by some change in the build system. That's why several packages were affected. For details see bug 995158. Sorry for inconvenience.

*** This bug has been marked as a duplicate of bug 995158 ***
Comment 7 Michal Jaegermann 2013-10-30 10:55:16 EDT
(In reply to Trevor Cordes from comment #3)

> I don't know, is it even possible for an updated RPM to clean up
> twice-installed packages or are we all stuck manually uninstalling as per
> comment #2?

   package-cleanup --noscripts --cleandupes

This requires 'yum-utils' to be installed.

Note You need to log in before you can comment on or make changes to this bug.