Bug 1001438 - RFE: feature rpc.idmapd add help -h option, to output "usage:" info
Summary: RFE: feature rpc.idmapd add help -h option, to output "usage:" info
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.0
Hardware: All
OS: Linux
high
low
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On:
Blocks: 1313485 1295577
TreeView+ depends on / blocked
 
Reported: 2013-08-27 04:39 UTC by JianHong Yin
Modified: 2016-11-04 04:59 UTC (History)
4 users (show)

Fixed In Version: nfs-utils-1.3.0-0.25.el7
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1001439 (view as bug list)
Environment:
Last Closed: 2016-11-04 04:59:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2383 0 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2016-11-03 13:53:02 UTC

Description JianHong Yin 2013-08-27 04:39:47 UTC
Description of problem:
[root@dhcp12-125 ~]# rpc.nfsd -h
Usage:
rpc.nfsd [-d|--debug] [-H hostname] [-p|-P|--port port] [-N|--no-nfs-version version] [-V|--nfs-version version] [-s|--syslog] [-T|--no-tcp] [-U|--no-udp] nrservs
[root@dhcp12-125 ~]# rpc.idmapd -h
rpc.idmapd: '-h' is an invalid argument.
[root@dhcp12-125 ~]# rpc.idmapd --help
rpc.idmapd: '--' is an invalid argument.

I think a unix/linux command should output the right usage, if specify invalid, or specify -h

Version-Release number of selected component (if applicable):
nfs-utils-1.2.8-2.0.el7.x86_64

How reproducible:


Steps to Reproduce:
1. rpc.idmapd -h 
2.
3.

Actual results:
[root@dhcp12-125 ~]# rpc.idmapd -h
rpc.idmapd: '-h' is an invalid argument.
[root@dhcp12-125 ~]# rpc.idmapd --help
rpc.idmapd: '--' is an invalid argument.

Expected results:
output the usage, if specify -h or --help
output the usage, if specify invalid option, notice and then output usage:

Additional info:

Comment 2 RHEL Program Management 2014-03-22 06:40:43 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 Steve Dickson 2015-12-16 17:04:46 UTC
Upstream commit
commit d91d3c0b4754284808dfd2c7faf64d0cd96c5ae7
Author: Steve Dickson <steved@redhat.com>
Date:   Fri Dec 11 11:10:12 2015 -0500

    rpc.idmapd: Added a usage routine
    
    Show the correct arguments when invalid
    arguments are used.
    
    Signed-off-by: Steve Dickson <steved@redhat.com>

Comment 5 Steve Dickson 2016-01-20 19:45:59 UTC
This is also needed

ommit e57642c50c9b2e409d1fc2775bdf88f64b344dd3
Author: Steve Dickson <steved@redhat.com>
Date:   Wed Jan 20 14:41:58 2016 -0500

    rpc.idmapd: Added the -h flag

Comment 6 Yongcheng Yang 2016-05-04 05:52:35 UTC
Hi Steve, to keep the man page consistency, do we need the following patch?

commit 02a96e351d403fc7caf4deed6b890b2e41ff9020
Author: Steve Dickson <steved@redhat.com>
Date:   Fri Dec 11 11:11:19 2015 -0500

    rpc.idmapd: Added the -C and -S flags
    
    The C and S flags were missing for the SYNOPSIS

Comment 7 Steve Dickson 2016-05-16 12:06:11 UTC
(In reply to Yongcheng Yang from comment #6)
> Hi Steve, to keep the man page consistency, do we need the following patch?
> 
> commit 02a96e351d403fc7caf4deed6b890b2e41ff9020
> Author: Steve Dickson <steved@redhat.com>
> Date:   Fri Dec 11 11:11:19 2015 -0500
> 
>     rpc.idmapd: Added the -C and -S flags
>     
>     The C and S flags were missing for the SYNOPSIS

I did pull it in... Please see nfs-utils-1.3.0-rpcidmapd-usage.patch

Comment 9 Yongcheng Yang 2016-05-18 03:01:54 UTC
Verified with nfs-utils-1.3.0-0.25.el7
Move to VERIFIED and continue to run the automatic case in the future.

[root@hp-dl585g7-04 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.25.el7.x86_64
[root@hp-dl585g7-04 ~]# 
[root@hp-dl585g7-04 ~]# rpc.idmapd -xxxx
rpc.idmapd: '-x' is an invalid argument.
Usage: rpc.idmapd [-hfvCS] [-p path] [-c path]
[root@hp-dl585g7-04 ~]# 
[root@hp-dl585g7-04 ~]# rpc.idmapd -h
Usage: rpc.idmapd [-hfvCS] [-p path] [-c path]
[root@hp-dl585g7-04 ~]# 

Reproduced with nfs-utils-1.3.0-0.21.el7
[root@hp-dl585g7-04 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.21.el7.x86_64
[root@hp-dl585g7-04 ~]# 
[root@hp-dl585g7-04 ~]# rpc.idmapd -xxxx
rpc.idmapd: '-x' is an invalid argument.
[root@hp-dl585g7-04 ~]# 
[root@hp-dl585g7-04 ~]# rpc.idmapd -h
rpc.idmapd: '-h' is an invalid argument.
[root@hp-dl585g7-04 ~]# echo $?
1
[root@hp-dl585g7-04 ~]#

Comment 10 Yongcheng Yang 2016-05-31 08:51:36 UTC
Move to VERIFIED as comment 9 and continue to run the automatic case

Comment 12 errata-xmlrpc 2016-11-04 04:59:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2383.html


Note You need to log in before you can comment on or make changes to this bug.