Bug 1001439 - rpc.idmapd add help -h option, to output "usage:" info
rpc.idmapd add help -h option, to output "usage:" info
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.4
All Linux
medium Severity low
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
:
Depends On:
Blocks: 1268411
  Show dependency treegraph
 
Reported: 2013-08-27 00:42 EDT by Yin.JianHong
Modified: 2016-05-10 20:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.3-67.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1001438
Environment:
Last Closed: 2016-05-10 20:02:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yin.JianHong 2013-08-27 00:42:07 EDT
+++ This bug was initially created as a clone of Bug #1001438 +++

Description of problem:
[root@dhcp12-125 ~]# rpc.nfsd -h
Usage:
rpc.nfsd [-d|--debug] [-H hostname] [-p|-P|--port port] [-N|--no-nfs-version version] [-V|--nfs-version version] [-s|--syslog] [-T|--no-tcp] [-U|--no-udp] nrservs
[root@dhcp12-125 ~]# rpc.idmapd -h
rpc.idmapd: '-h' is an invalid argument.
[root@dhcp12-125 ~]# rpc.idmapd --help
rpc.idmapd: '--' is an invalid argument.

I think a unix/linux command should output the right usage, if specify invalid, or specify -h

Version-Release number of selected component (if applicable):
#nfs-utils-1.2.8-2.0.el7.x86_64
nfs-utils-1.2.3-36.el6.x86_64

How reproducible:


Steps to Reproduce:
1. rpc.idmapd -h 
2.
3.

Actual results:
[root@dhcp12-125 ~]# rpc.idmapd -h
rpc.idmapd: '-h' is an invalid argument.
[root@dhcp12-125 ~]# rpc.idmapd --help
rpc.idmapd: '--' is an invalid argument.

Expected results:
output the usage, if specify -h or --help
output the usage, if specify invalid option, notice and then output usage:

Additional info:
Comment 2 RHEL Product and Program Management 2013-10-13 22:32:50 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Steve Dickson 2015-10-26 08:21:53 EDT
This is an easy fix....
Comment 6 Steve Dickson 2015-12-16 12:02:21 EST
Upstream commit
commit d91d3c0b4754284808dfd2c7faf64d0cd96c5ae7
Author: Steve Dickson <steved@redhat.com>
Date:   Fri Dec 11 11:10:12 2015 -0500

    rpc.idmapd: Added a usage routine
    
    Show the correct arguments when invalid
    arguments are used.
    
    Signed-off-by: Steve Dickson <steved@redhat.com>
Comment 9 Yongcheng Yang 2016-02-17 23:43:58 EST
Move to VERIFIED as Comment 8
Comment 11 errata-xmlrpc 2016-05-10 20:02:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0868.html

Note You need to log in before you can comment on or make changes to this bug.