Bug 1001636 - [Account] Add locking mechanism
[Account] Add locking mechanism
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openlmi-providers (Show other bugs)
7.1
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Tomáš Bžatek
Robin Hack
: Rebase, Reopened
: 1001016 (view as bug list)
Depends On:
Blocks: 1001490
  Show dependency treegraph
 
Reported: 2013-08-27 08:35 EDT by Robin Hack
Modified: 2015-03-03 18:06 EST (History)
3 users (show)

See Also:
Fixed In Version: openlmi-providers-0.3.0-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:38:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Roman Rakus 2013-08-27 09:09:28 EDT
reopening - I will take a look on this anyway. Seems the problem is in libuser - it is not able to handle more requests in short time.

"backup file size mismatch" is message from lu_files_create_backup() in libuser. I think it is used to create temp backup file of /etc/passwd (or other modified file). I think it is due to handling too much requests in short time.
Comment 4 Roman Rakus 2013-08-28 09:10:01 EDT
This is locking issue - Will implement some (basic) locking.
Comment 5 Roman Rakus 2013-09-04 08:08:24 EDT
*** Bug 1001016 has been marked as a duplicate of this bug. ***
Comment 9 Robin Hack 2014-01-08 03:54:03 EST
This has been partialy fixed in AccountProvider (only in little part of code).
But still there will be troubles with locking and race conditions.

Should I made this pass?
Comment 12 Ludek Smid 2014-06-13 05:38:35 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.