Bug 1001714 - [abrt] xonotic-0.7.0-1.fc19: ft_mem_qalloc: Process /usr/bin/xonotic-sdl was killed by signal 6 (SIGABRT)
Summary: [abrt] xonotic-0.7.0-1.fc19: ft_mem_qalloc: Process /usr/bin/xonotic-sdl was ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6b93e47bc140be7c723e90c1e94...
Depends On: 1002506 1006733
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-27 15:00 UTC by Elias Vanderstuyft
Modified: 2013-09-23 00:45 UTC (History)
4 users (show)

Fixed In Version: mesa-9.2-1.20130919.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-20 16:19:50 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (17.66 KB, text/plain)
2013-08-27 15:00 UTC, Elias Vanderstuyft
no flags Details
File: cgroup (140 bytes, text/plain)
2013-08-27 15:00 UTC, Elias Vanderstuyft
no flags Details
File: core_backtrace (6.99 KB, text/plain)
2013-08-27 15:00 UTC, Elias Vanderstuyft
no flags Details
File: dso_list (7.72 KB, text/plain)
2013-08-27 15:01 UTC, Elias Vanderstuyft
no flags Details
File: environ (3.10 KB, text/plain)
2013-08-27 15:01 UTC, Elias Vanderstuyft
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-27 15:01 UTC, Elias Vanderstuyft
no flags Details
File: maps (39.66 KB, text/plain)
2013-08-27 15:01 UTC, Elias Vanderstuyft
no flags Details
File: open_fds (807 bytes, text/plain)
2013-08-27 15:01 UTC, Elias Vanderstuyft
no flags Details
File: proc_pid_status (937 bytes, text/plain)
2013-08-27 15:01 UTC, Elias Vanderstuyft
no flags Details
File: var_log_messages (918 bytes, text/plain)
2013-08-27 15:01 UTC, Elias Vanderstuyft
no flags Details


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 68665 0 None None None Never
Red Hat Bugzilla 1001698 0 unspecified CLOSED [abrt] supertuxkart-0.8-1.fc19: pushbuf_flush: Process /usr/bin/supertuxkart was killed by signal 11 (SIGSEGV) 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1001740 0 unspecified CLOSED [abrt] extremetuxracer-0.4-12.fc19: pushbuf_dump: Process /usr/bin/etracer was killed by signal 11 (SIGSEGV) 2021-02-22 00:41:40 UTC

Internal Links: 1001698 1001740

Description Elias Vanderstuyft 2013-08-27 15:00:46 UTC
Description of problem:
Set AA (x2) and then click 'Apply changes' crashes the game with nouveau on Nvidia GTX 760.

Version-Release number of selected component:
xonotic-0.7.0-1.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        xonotic-sdl
crash_function: ft_mem_qalloc
executable:     /usr/bin/xonotic-sdl
kernel:         3.10.9-200.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 ft_mem_qalloc at /usr/src/debug/freetype-2.4.11/src/base/ftutil.c:76
 #7 ft_mem_alloc at /usr/src/debug/freetype-2.4.11/src/base/ftutil.c:55
 #8 FT_Add_Module at /usr/src/debug/freetype-2.4.11/src/base/ftobjs.c:4179
 #9 FT_Add_Default_Modules at /usr/src/debug/freetype-2.4.11/src/base/ftinit.c:218
 #10 FT_Init_FreeType at /usr/src/debug/freetype-2.4.11/src/base/ftinit.c:255
 #11 font_start at ft2.c:302
 #12 gl_draw_start at gl_draw.c:1013
 #13 R_Modules_Start at r_modules.c:62
 #14 VID_OpenSystems at vid_shared.c:1889
 #15 VID_Restart_f at vid_shared.c:1927

Comment 1 Elias Vanderstuyft 2013-08-27 15:00:51 UTC
Created attachment 791031 [details]
File: backtrace

Comment 2 Elias Vanderstuyft 2013-08-27 15:00:54 UTC
Created attachment 791032 [details]
File: cgroup

Comment 3 Elias Vanderstuyft 2013-08-27 15:00:58 UTC
Created attachment 791033 [details]
File: core_backtrace

Comment 4 Elias Vanderstuyft 2013-08-27 15:01:01 UTC
Created attachment 791034 [details]
File: dso_list

Comment 5 Elias Vanderstuyft 2013-08-27 15:01:05 UTC
Created attachment 791035 [details]
File: environ

Comment 6 Elias Vanderstuyft 2013-08-27 15:01:09 UTC
Created attachment 791037 [details]
File: limits

Comment 7 Elias Vanderstuyft 2013-08-27 15:01:19 UTC
Created attachment 791038 [details]
File: maps

Comment 8 Elias Vanderstuyft 2013-08-27 15:01:22 UTC
Created attachment 791039 [details]
File: open_fds

Comment 9 Elias Vanderstuyft 2013-08-27 15:01:25 UTC
Created attachment 791040 [details]
File: proc_pid_status

Comment 10 Elias Vanderstuyft 2013-08-27 15:01:31 UTC
Created attachment 791041 [details]
File: var_log_messages

Comment 11 Igor Gnatenko 2013-08-28 14:25:33 UTC
I think problem in mesa. Not xonotic.

Comment 12 Igor Gnatenko 2013-09-05 06:04:14 UTC
Update was pushed to stable. Update please. If you will have again this problem - reopen please.

Comment 13 Elias Vanderstuyft 2013-09-05 08:08:53 UTC
*** Bug 1004674 has been marked as a duplicate of this bug. ***

Comment 14 Elias Vanderstuyft 2013-09-05 08:12:17 UTC
Retested with mesa-9.2-1.20130902.fc19, problem persists.

Comment 15 Igor Gnatenko 2013-09-05 11:08:45 UTC
Test this build please: http://koji.fedoraproject.org/koji/taskinfo?taskID=5898642

Comment 16 Elias Vanderstuyft 2013-09-05 21:21:51 UTC
I'm sorry, for the next 20 hours, I'm not available. I'll test as soon as possible.

Comment 17 Elias Vanderstuyft 2013-09-06 18:30:45 UTC
I can confirm the bug is fixed with the x86_64 packages from http://koji.fedoraproject.org/koji/taskinfo?taskID=5898642
Tested with all AA options: off, x2 and x4
No crashes (or graphical glitches.)

Comment 18 Igor Gnatenko 2013-09-06 18:36:29 UTC
Ok. informed upstream. Take this bug.

Comment 19 Igor Gnatenko 2013-09-11 07:36:59 UTC
please test: http://koji.fedoraproject.org/koji/taskinfo?taskID=5921732

Comment 20 Elias Vanderstuyft 2013-09-18 10:46:04 UTC
I can confirm the bug is fixed with the x86_64 packages from http://koji.fedoraproject.org/koji/taskinfo?taskID=5921732
Tested with all AA options: off, x2 and x4
No crashes (or graphical glitches.)

Comment 21 Igor Gnatenko 2013-09-18 17:44:10 UTC
Many thanks for reporting and testing. Waiting for bug 1006733.

Comment 22 Fedora Update System 2013-09-19 08:03:02 UTC
mesa-9.2-1.20130919.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mesa-9.2-1.20130919.fc19

Comment 23 Fedora Update System 2013-09-19 08:20:14 UTC
mesa-9.2-1.20130919.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mesa-9.2-1.20130919.fc20

Comment 24 Fedora Update System 2013-09-19 18:32:47 UTC
Package mesa-9.2-1.20130919.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mesa-9.2-1.20130919.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17132/mesa-9.2-1.20130919.fc20
then log in and leave karma (feedback).

Comment 25 Elias Vanderstuyft 2013-09-20 08:58:19 UTC
I can confirm the bug is fixed with the x86_64 packages from http://koji.fedoraproject.org/koji/buildinfo?buildID=465600
Tested with all AA options: off, x2 and x4
No crashes (or graphical glitches.)

Comment 26 Igor Gnatenko 2013-09-20 08:59:23 UTC
Thanks for reporting and testing

Comment 27 Fedora Update System 2013-09-20 16:19:50 UTC
mesa-9.2-1.20130919.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2013-09-23 00:45:27 UTC
mesa-9.2-1.20130919.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.