Bug 1001777 - SELinux is preventing /usr/bin/convert from 'unlink' accesses on the file magickgRwLy6.
SELinux is preventing /usr/bin/convert from 'unlink' accesses on the file mag...
Status: CLOSED DUPLICATE of bug 825874
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
abrt_hash:685fab5b6bc162f71fe6272bd49...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 13:50 EDT by José Antonio
Modified: 2013-08-31 12:15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 12:15:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description José Antonio 2013-08-27 13:50:27 EDT
Description of problem:
SELinux is preventing /usr/bin/convert from 'unlink' accesses on the file magickgRwLy6.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that convert should be allowed unlink access on the magickgRwLy6 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep convert /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                magickgRwLy6 [ file ]
Source                        convert
Source Path                   /usr/bin/convert
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ImageMagick-6.7.8.9-5.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-73.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.9-200.fc19.x86_64 #1 SMP Wed
                              Aug 21 19:27:58 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-08-27 18:49:28 WEST
Last Seen                     2013-08-27 18:49:28 WEST
Local ID                      9af9038f-6e86-41cb-b2b7-99e7eb53c2d2

Raw Audit Messages
type=AVC msg=audit(1377625768.949:2031): avc:  denied  { unlink } for  pid=9533 comm="convert" name="magickgRwLy6" dev="dm-2" ino=7867577 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file


type=SYSCALL msg=audit(1377625768.949:2031): arch=x86_64 syscall=unlink success=yes exit=0 a0=25353d0 a1=c2 a2=180 a3=7fffb3e21730 items=0 ppid=9518 pid=9533 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=13 tty=(none) comm=convert exe=/usr/bin/convert subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)

Hash: convert,thumb_t,user_home_dir_t,file,unlink

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.9-200.fc19.x86_64
type:           libreport

Potential duplicate: bug 862147
Comment 1 Daniel Walsh 2013-08-28 14:02:16 EDT
ImageMagick should be putting its content into  a subdir like .cache/ImageMagick
Comment 2 Pavel Alexeev 2013-08-31 12:15:09 EDT
It is duplicate.

If you are have reproduce and willing make it forward by providing more info and try some builds you may ask in linked bz#825874

*** This bug has been marked as a duplicate of bug 825874 ***

Note You need to log in before you can comment on or make changes to this bug.