Bug 1001894 - abrt-handle-event segfaults on post-create stage
abrt-handle-event segfaults on post-create stage
Status: CLOSED DUPLICATE of bug 997076
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Marko
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 00:46 EDT by Mamoru TASAKA
Modified: 2016-01-31 21:23 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 10:10:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb log for abrt-handle-event (4.97 KB, text/plain)
2013-08-28 00:46 EDT, Mamoru TASAKA
no flags Details

  None (edit)
Description Mamoru TASAKA 2013-08-28 00:46:25 EDT
Created attachment 791249 [details]
gdb log for abrt-handle-event

Description of problem:
When abrt detects some application's segfault, abrt-handle-event-coredump
segfaults at post-create stage and I cannot submit bug report using abrt.


Version-Release number of selected component (if applicable):
abrt-2.1.6-3.fc19.i686

How reproducible:
100%

Steps to Reproduce:
1. Find out some application (in rpm) which segfaults and make it
   segfault, or just send SIGSEGV signal
2. Watch
3.

Actual results:
/var/log/messages:


Aug 28 13:27:24 localhost abrtd: Directory 'ccpp-2013-08-28-13:27:23-2136' creation detected
Aug 28 13:27:24 localhost abrt[2385]: Saved core dump of pid 2136 (/usr/bin/pcmanfm) to /var/tmp/abrt/ccpp-2013-08-28-13:27:23-2136 (100114432 bytes)
Aug 28 13:27:24 localhost abrtd: Can't load public GPG key /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
Aug 28 13:27:24 localhost abrtd: Generating core_backtrace
Aug 28 13:27:24 localhost abrtd: バックトレースの生成中
Aug 28 13:27:25 localhost abrt: detected unhandled Python exception
Aug 28 13:27:28 localhost abrt: detected unhandled Python exception
Aug 28 13:27:32 localhost kernel: [  165.878327] abrt-handle-eve[2386]: segfault at 0 ip b73cb224 sp bfdcd930 error 4 in libsatyr.so.1.0.0[b73bb000+2e000]
Aug 28 13:27:32 localhost abrt[2423]: Saved core dump of pid 2386 (/usr/libexec/abrt-handle-event) to /var/tmp/abrt/abrt-handle-event-coredump (1011712 bytes)
Aug 28 13:27:32 localhost abrtd: 'post-create' on '/var/tmp/abrt/ccpp-2013-08-28-13:27:23-2136' killed by signal 11
Aug 28 13:27:32 localhost abrtd: Deleting problem directory '/var/tmp/abrt/ccpp-2013-08-28-13:27:23-2136'


Expected results:
abrt-handle-event should not segfault

Additional info:
gdb result for abrt-handle-event attached
Comment 1 Michael Schwendt 2013-09-03 17:19:41 EDT
Same with Fedora 20:

Sep  3 23:16:34 faldor kernel: [46404.939515] traps: xzgv[29900] general protection ip:3335614ff4 sp:7ffffb2bb670 error:0 in libgobject-2.0.so.0.3706.0[3335600000+50000]
Sep  3 23:16:34 faldor abrtd: Directory 'ccpp-2013-09-03-23:16:34-29900' creation detected
Sep  3 23:16:34 faldor abrt[29901]: Saved core dump of pid 29900 (/usr/bin/xzgv) to /var/tmp/abrt/ccpp-2013-09-03-23:16:34-29900 (4890624 bytes)
Sep  3 23:16:34 faldor abrtd: Can't load public GPG key /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
Sep  3 23:16:34 faldor abrtd: Generating core_backtrace
Sep  3 23:16:34 faldor abrtd: Generating backtrace
Sep  3 23:16:35 faldor kernel: [46406.169009] abrt-handle-eve[29902]: segfault at 0 ip 00007fd521b61134 sp 00007fff7d712440 error 4 in libsatyr.so.1.0.0[7fd521b0a000+139000]
Sep  3 23:16:35 faldor abrt[29938]: Saved core dump of pid 29902 (/usr/libexec/abrt-handle-event) to /var/tmp/abrt/abrt-handle-event-coredump (1753088 bytes)
Sep  3 23:16:35 faldor abrtd: 'post-create' on '/var/tmp/abrt/ccpp-2013-09-03-23:16:34-29900' killed by signal 11
Sep  3 23:16:35 faldor abrtd: Deleting problem directory '/var/tmp/abrt/ccpp-2013-09-03-23:16:34-29900'
Comment 2 Richard Marko 2013-09-04 03:55:09 EDT
I have a fix ready for the crash but the root cause is that one of the 'core_backtrace' files is most probably incomplete.

It would be helpful if you go through directories in /var/tmp/abrt and try to find 'core_backtrace' which seems incomplete (e.g. has empty stacktrace field) and post it here as an attachment along with 'backtrace' file (if it doesn't contain anything sensitive) so we can debug why it was generated like that.

Thanks!
Comment 3 Richard Marko 2013-09-09 10:10:51 EDT

*** This bug has been marked as a duplicate of bug 997076 ***

Note You need to log in before you can comment on or make changes to this bug.