This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1001998 - Firefox (download) notifications no longer show up in the gnome 3 message tray
Firefox (download) notifications no longer show up in the gnome 3 message tray
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 1023280 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 05:46 EDT by Hans de Goede
Modified: 2014-10-16 10:26 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-16 10:26:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2013-08-28 05:46:31 EDT
In Fedora-19 firefox's notifications integrate nicely with gnome-3, showing things like downloads complete in the gnome-3 message tray.

Something has broken this in Fedora-20, in Fedora 20 firefox uses "old style" notifications in the top right corner of the screen.
Comment 1 Vít Ondruch 2013-10-07 10:35:01 EDT
This is not F20 specific. I first noticed the same issue on F19. There are similar issues in KDE (see bug 1002897).
Comment 2 Hans de Goede 2013-10-12 06:51:14 EDT
Note I've recently (after a thunderbird upgrade) noticed that thunderbird is no showing the same problem.
Comment 3 Vít Ondruch 2013-10-14 03:02:46 EDT
(In reply to Hans de Goede from comment #2)
> Note I've recently (after a thunderbird upgrade) noticed that thunderbird is
> no showing the same problem.

I can't agree. TB is even more annoying than FF. I was even thinking about disabling TB notifications due to this.

$ rpm -q thunderbird
thunderbird-24.0-3.fc20.x86_64
Comment 4 Martin Stransky 2013-10-14 08:26:37 EDT
It's because mozilla is redesigning the notification - https://bugzilla.mozilla.org/show_bug.cgi?id=782211
Comment 5 Martin Stransky 2013-10-14 08:36:53 EDT
The Thunderbird bug - https://bugzilla.mozilla.org/show_bug.cgi?id=853104
Comment 6 Martin Stransky 2013-10-14 08:41:16 EDT
Discussion to this topics: https://groups.google.com/forum/#!topic/mozilla.dev.platform/77i4nntE2Ug
Comment 7 Martin Stransky 2013-10-15 07:11:58 EDT
Unfortunately libnotify does not support all features needed by Mozilla notification system (which it's used for WebApps too).
Comment 8 Martin Stransky 2013-10-25 02:28:21 EDT
*** Bug 1023280 has been marked as a duplicate of this bug. ***
Comment 9 Jóhann B. Guðmundsson 2013-10-25 02:36:12 EDT
Note this is affects F18 as well and seems to be 101 example how not to be maintaining and pushing things into GA releases...
Comment 10 Martin Stransky 2013-10-25 02:56:20 EDT
(In reply to Jóhann B. Guðmundsson from comment #9)
> Note this is affects F18 as well and seems to be 101 example how not to be
> maintaining and pushing things into GA releases...

Unfortunately Mozilla rewrote the notification engine and drop libnotify backend because libnotify does not support all features Firefox needs (like clickable events).

There isn't an easy fix for that - libnotify needs to be extended or we can write a partial libnotify support - but it's not something we can do in short timeframe.
Comment 11 Jóhann B. Guðmundsson 2013-10-25 03:10:15 EDT
(In reply to Martin Stransky from comment #10)
> (In reply to Jóhann B. Guðmundsson from comment #9)
> > Note this is affects F18 as well and seems to be 101 example how not to be
> > maintaining and pushing things into GA releases...
> 
> Unfortunately Mozilla rewrote the notification engine and drop libnotify
> backend because libnotify does not support all features Firefox needs (like
> clickable events).
> 
> There isn't an easy fix for that - libnotify needs to be extended or we can
> write a partial libnotify support - but it's not something we can do in
> short timeframe.

Yes but the proper way to handle this would have been to stick to the tb that did not break this then to backport the necessary patches from tb without breaking the notification people are used to in GA releases and ones the notification support would be in place update both components.
Comment 12 Martin Stransky 2013-10-25 03:19:31 EDT
The change affects Thunderbird as well. The old notification support has been removed from all new Mozilla products. The "backport" here means to revert the new notification API and use the old one. I'm not sure how long we can maintain Fedora specific patch would be ~1-2MB big and goes outdated with every new release.
Comment 13 Jóhann B. Guðmundsson 2013-10-25 03:44:49 EDT
(In reply to Martin Stransky from comment #12)
> The change affects Thunderbird as well. The old notification support has
> been removed from all new Mozilla products. The "backport" here means to
> revert the new notification API and use the old one. I'm not sure how long
> we can maintain Fedora specific patch would be ~1-2MB big and goes outdated
> with every new release.


TB should never have been updated in the GA releases until this was resolved, It's an very noticeable change for users and it's simply is the price to pay being a distribution maintainer for Mozilla when they make changes like this. 

Looking at the upstream report the libnotify maintainer(s) have had atleast since Mars more if the mozilla dev gave them a heads up before removing/implementing their notification changes to the core api.
Comment 14 Vít Ondruch 2013-10-25 04:15:25 EDT
JFYI, I am not sure what is the future of libnotify, since it seems that it is going to be replaced by something else: http://blogs.gnome.org/mclasen/2013/10/14/montreal-summit/ May be Gnome could at least collaborate with Mozilla to find some common specification of notifications.
Comment 15 leigh scott 2013-11-27 15:32:27 EST
(In reply to Martin Stransky from comment #12)
> The change affects Thunderbird as well. The old notification support has
> been removed from all new Mozilla products. The "backport" here means to
> revert the new notification API and use the old one. I'm not sure how long
> we can maintain Fedora specific patch would be ~1-2MB big and goes outdated
> with every new release.

It looks fairly easy to revert this for thunderbird (9.5kb)

http://leigh123linux.fedorapeople.org/pub/patches/revert-removal-of-native-notifications.patch
Comment 16 Martin Stransky 2013-12-11 03:38:45 EST
Yes, it's because Thunderbird is based on Firefox 24 ESR so it's not changed so heavily. I'm going to test the patch, it may buy us some time. But it's a temporary solution and obsoleted by Firefox/Thunderbird 32.
Comment 17 leigh scott 2013-12-16 07:16:12 EST
(In reply to Martin Stransky from comment #16)
> Yes, it's because Thunderbird is based on Firefox 24 ESR so it's not changed
> so heavily. I'm going to test the patch, it may buy us some time. But it's a
> temporary solution and obsoleted by Firefox/Thunderbird 32.

Thank you.
Comment 19 Hans de Goede 2014-10-16 08:14:06 EDT
Hi Martin,

(In reply to Martin Stransky from comment #18)
> Please test new packages with new upstream patches:
> 
> http://koji.fedoraproject.org/koji/buildinfo?buildID=585608
> http://koji.fedoraproject.org/koji/buildinfo?buildID=585611
> http://koji.fedoraproject.org/koji/buildinfo?buildID=585609

Thanks for your work on this! AFAIK firefox no longer shows download completions as system notifcations, instead it only changes the collor of the download error in its own UI now. At least I do not remember seeing any of the old-style notifications for a couple of firefox releases now.

So although I would love to test this for you, I've no idea how to test :|
Comment 20 Martin Stransky 2014-10-16 10:26:08 EDT
Okay, Thanks. So closing for now.

Note You need to log in before you can comment on or make changes to this bug.