Bug 1002055 - [abrt] gnome-shell-3.9.90-1.fc20: g_variant_valist_new_nnp: Process /usr/bin/gnome-shell was killed by signal 5 (SIGTRAP)
[abrt] gnome-shell-3.9.90-1.fc20: g_variant_valist_new_nnp: Process /usr/bin/...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
20
i686 Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
abrt_hash:cbfb60d708cadfbd3b1a248d507...
:
: 1003160 (view as bug list)
Depends On:
Blocks: F20AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-08-28 07:56 EDT by Kamil Páral
Modified: 2013-09-06 08:59 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-06 08:59:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (45.44 KB, text/plain)
2013-08-28 07:56 EDT, Kamil Páral
no flags Details
File: cgroup (159 bytes, text/plain)
2013-08-28 07:56 EDT, Kamil Páral
no flags Details
File: core_backtrace (23.79 KB, text/plain)
2013-08-28 07:56 EDT, Kamil Páral
no flags Details
File: dso_list (20.84 KB, text/plain)
2013-08-28 07:56 EDT, Kamil Páral
no flags Details
File: environ (1.17 KB, text/plain)
2013-08-28 07:56 EDT, Kamil Páral
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-28 07:57 EDT, Kamil Páral
no flags Details
File: maps (60.73 KB, text/plain)
2013-08-28 07:57 EDT, Kamil Páral
no flags Details
File: open_fds (3.07 KB, text/plain)
2013-08-28 07:57 EDT, Kamil Páral
no flags Details
File: proc_pid_status (794 bytes, text/plain)
2013-08-28 07:57 EDT, Kamil Páral
no flags Details
journal from the second attempt (576.67 KB, text/plain)
2013-08-28 08:17 EDT, Kamil Páral
no flags Details
initial screen screenshot (146.38 KB, image/jpeg)
2013-08-28 08:17 EDT, Kamil Páral
no flags Details
screen after cancelling welcome dialog (171.72 KB, image/jpeg)
2013-08-28 08:18 EDT, Kamil Páral
no flags Details
coredump with mutter-3.9.90-2.fc20 (2.75 MB, application/x-xz)
2013-08-30 11:16 EDT, Kamil Páral
no flags Details
gnome packages build 20130904 - 16:30 CEST (2.56 KB, text/plain)
2013-09-04 10:36 EDT, Dethlef Madsen
no flags Details

  None (edit)
Description Kamil Páral 2013-08-28 07:56:34 EDT
Description of problem:
I put F20 Alpha TC1 i386 Live onto USB flash drive using dd and then booted it on this computer. It contains nvidia graphics and there's some kernel error during boot, I don't know whether it is related. After boot, I see just "Oh no something's wrong" screen.

Version-Release number of selected component:
gnome-shell-3.9.90-1.fc20

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: g_variant_valist_new_nnp
executable:     /usr/bin/gnome-shell
kernel:         3.11.0-0.rc6.git4.1.fc20.i686
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 g_variant_valist_new_nnp at gvariant.c:4159
 #3 g_variant_valist_new_leaf at gvariant.c:4387
 #4 g_variant_valist_new at gvariant.c:4569
 #6 g_variant_new_va at gvariant.c:4778
 #7 g_variant_builder_add at gvariant.c:4930
 #8 meta_monitor_manager_handle_get_resources at core/monitor.c:839
 #9 ffi_call_SYSV at ../src/x86/sysv.S:65
 #10 ffi_call at ../src/x86/ffi.c:411
 #11 g_cclosure_marshal_generic at gclosure.c:1454
 #12 g_type_iface_meta_marshal at gclosure.c:1021

Potential duplicate: bug 707996
Comment 1 Kamil Páral 2013-08-28 07:56:38 EDT
Created attachment 791351 [details]
File: backtrace
Comment 2 Kamil Páral 2013-08-28 07:56:42 EDT
Created attachment 791352 [details]
File: cgroup
Comment 3 Kamil Páral 2013-08-28 07:56:46 EDT
Created attachment 791353 [details]
File: core_backtrace
Comment 4 Kamil Páral 2013-08-28 07:56:51 EDT
Created attachment 791354 [details]
File: dso_list
Comment 5 Kamil Páral 2013-08-28 07:56:58 EDT
Created attachment 791355 [details]
File: environ
Comment 6 Kamil Páral 2013-08-28 07:57:02 EDT
Created attachment 791356 [details]
File: limits
Comment 7 Kamil Páral 2013-08-28 07:57:05 EDT
Created attachment 791357 [details]
File: maps
Comment 8 Kamil Páral 2013-08-28 07:57:10 EDT
Created attachment 791358 [details]
File: open_fds
Comment 9 Kamil Páral 2013-08-28 07:57:13 EDT
Created attachment 791359 [details]
File: proc_pid_status
Comment 10 Kamil Páral 2013-08-28 08:13:56 EDT
I tried to reproduce bug 1002055 on a different computer (amd graphics). Same media.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: g_variant_valist_new_nnp
executable:     /usr/bin/gnome-shell
kernel:         3.11.0-0.rc6.git4.1.fc20.i686
package:        gnome-shell-3.9.90-1.fc20
reason:         Process /usr/bin/gnome-shell was killed by signal 5 (SIGTRAP)
reported_to:    uReport: BTHASH=e0915aabecbda2a74620cb9e19240e509d1fe637
runlevel:       N 5
uid:            1000
Comment 11 Kamil Páral 2013-08-28 08:17:09 EDT
Created attachment 791367 [details]
journal from the second attempt
Comment 12 Kamil Páral 2013-08-28 08:17:50 EDT
Created attachment 791369 [details]
initial screen screenshot
Comment 13 Kamil Páral 2013-08-28 08:18:22 EDT
Created attachment 791370 [details]
screen after cancelling welcome dialog
Comment 14 Kamil Páral 2013-08-28 08:33:04 EDT
Reproduced on three different computers with two different USB media. Reproduced with dd, livecd-iso-to-disk and liveusb-creator.

Proposing as a blocker:
Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with at least one of the officially supported methods.
https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Expected_image_boot_behavior
Comment 15 Kamil Páral 2013-08-28 08:35:24 EDT
Oh, and the same issue is reproduced with CD in KVM, so this is not related to USB conversion at all.
Comment 16 Kamil Páral 2013-08-28 13:14:33 EDT
Discussed at 2013-08-28 blocker review meeting [1]. This is accepted as an Alpha blocker, because it violates the following F20 alpha release criterion for the 32bit desktop spin: "Release-blocking live images must boot to the expected boot menu, and then to a desktop or to a login prompt where it is clear how to log in to a desktop." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-08-28/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Expected_image_boot_behavior
Comment 17 drago01 2013-08-30 09:48:27 EDT
Can you please retest with that build http://koji.fedoraproject.org/koji/taskinfo?taskID=5873826 (one it is done) ?
Comment 18 Kamil Páral 2013-08-30 10:18:25 EDT
I tried to build my own LiveCD, but there seem to be broken some dependencies. And even if I succeeded, RelEng probably uses a different build process. So ideally we need to have it included in the next TestCompose. However, we need a non-scratch build for that.

Please make a non-scratch build and switch this bug's status to MODIFIED. It will be picked up for the next TC.

Thanks.
Comment 19 Giovanni Campagna 2013-08-30 10:55:44 EDT
Can you instead install the scratch rpm on the existing TC2 live cd?

Also, would it be possible to have the full coredump, or even better a gdb session where you try to look around at the level of meta_monitor_manager_handle_get_resources() and see if anything is obviously garbage?
Comment 20 drago01 2013-08-30 11:10:27 EDT
(In reply to Kamil Páral from comment #18)
> I tried to build my own LiveCD,  [...]

You can just do 

yum install http://kojipkgs.fedoraproject.org//work/tasks/3828/5873828/mutter-3.9.90-2.fc20.x86_64.rpm

And restart your session.
Comment 21 Kamil Páral 2013-08-30 11:16:16 EDT
Created attachment 792218 [details]
coredump with mutter-3.9.90-2.fc20

(In reply to Giovanni Campagna from comment #19)
> Can you instead install the scratch rpm on the existing TC2 live cd?

Good idea. I did, restarted gdm, but it did not help, still the same screen.

> Also, would it be possible to have the full coredump,

Attached, using the new mutter.

> or even better a gdb
> session where you try to look around at the level of
> meta_monitor_manager_handle_get_resources() and see if anything is obviously
> garbage?

I'm afraid I don't have the required gdb skills. Please do try it, the image is here:
http://dl.fedoraproject.org/pub/alt/stage/20-Alpha-TC2/Live/i386/Fedora-Live-Desktop-i686-20-Alpha-TC2-1.iso
Comment 22 Dethlef Madsen 2013-08-30 14:34:04 EDT
Just want to tell that the new mutter-3.9.90-2.fc20.x86_64.rpm did it for me. May be another bug but I had the same effects like Kamil. 

My system is a HP 5750 with AMD dual-core 64-bit CPU and AMD/ATI X1100/1150 mobile grafic chip. Before the new mutter I added radeon.modeset=0 to the kernel cmd-line and it works but the grafic was slow. 

This is true for 64-bit. If I boot the 32-bit TC2-iso form usb flashdrive the new mutter-3.9.90-2.fc20.i686.rpm has no effect. With radeon.modeset=0 it works again.

I you need some logs please ask.

Regards,

DM
Comment 23 Giovanni Campagna 2013-09-02 03:26:49 EDT
Oh I get the problem, this is 32 bits! That explains why it wasn't crashing for me.

Ok, so I just need to cast all the varargs to the right size...
Comment 24 Andre Robatino 2013-09-02 03:34:43 EDT
*** Bug 1003160 has been marked as a duplicate of this bug. ***
Comment 25 Christopher Meng 2013-09-03 21:42:09 EDT
Please fix this problem in .90 as I can't use GNOME after updating to this version for already 2 weeks.
Comment 26 drago01 2013-09-04 02:51:45 EDT
(In reply to Christopher Meng from comment #25)
> Please fix this problem in .90 as I can't use GNOME after updating to this
> version for already 2 weeks.

.91 packages are being built right now:

http://koji.fedoraproject.org/koji/buildinfo?buildID=461273
http://koji.fedoraproject.org/koji/buildinfo?buildID=461412
Comment 27 Jaroslav Reznik 2013-09-04 07:37:27 EDT
Can anybody retry it with the latest builds?
Comment 28 Dethlef Madsen 2013-09-04 09:16:19 EDT
(In reply to Jaroslav Reznik from comment #27)
> Can anybody retry it with the latest builds?

Looks good so far but I cant do a full update on my stick. There are still missing depends. Seems koji is still working on the rest the files. 

But a 

# yum update mutter gnome-shell

and init 5 brings you to the normal screen now on i686 and is performant.

I will try a full update later.
Comment 29 Christopher Meng 2013-09-04 09:21:34 EDT
Wow....I just tried .90 again with some gnome updates pushed yesterday.

Better and more smooth interface since last time I could login ;)

But still has crashes and network connection is not stable.

When I use botton on my laptop to enable/disable wifi, it crashed, but alt+tab switch could work so it didn't affect me.

[rpmaker@fab ~]$ rpm -qa|grep gnome-shell
gnome-shell-extension-window-list-3.9.90-1.fc21.noarch
gnome-shell-extension-user-theme-3.9.90-1.fc21.noarch
gnome-shell-extension-places-menu-3.9.90-1.fc21.noarch
gnome-shell-3.9.90-1.fc21.i686
gnome-shell-extension-apps-menu-3.9.90-1.fc21.noarch
gnome-shell-extension-launch-new-instance-3.9.90-1.fc21.noarch
gnome-shell-extension-alternate-tab-3.9.90-1.fc21.noarch
gnome-shell-extension-common-3.9.90-1.fc21.noarch
Comment 30 Christopher Meng 2013-09-04 09:22:44 EDT
[rpmaker@fab ~]$ rpm -qa|grep gnome
clearlooks-compact-gnome-theme-1.5-6.fc18.noarch
NetworkManager-openvpn-gnome-0.9.8.2-3.fc21.i686
gnome-user-docs-3.9.90-1.fc21.noarch
gnome-font-viewer-3.9.90-1.fc21.i686
gnome-icon-theme-legacy-3.9.5-1.fc20.noarch
gnome-bluetooth-3.9.3-4.fc20.i686
gnome-screenshot-3.9.90-1.fc21.i686
gnome-shell-extension-window-list-3.9.90-1.fc21.noarch
gnome-desktop3-3.9.90-1.fc21.i686
gnome-clocks-3.9.3-2.fc20.i686
gnome-documents-3.9.90-1.fc21.i686
gnome-packagekit-3.8.2-2.fc20.i686
gnome-online-accounts-3.9.90-2.fc21.i686
gnome-python2-canvas-2.28.1-13.fc20.i686
libgnomeprint22-2.18.8-6.fc19.i686
gnome-python2-gnomekeyring-2.32.0-15.fc20.i686
gnome-shell-extension-user-theme-3.9.90-1.fc21.noarch
gnome-python2-gtkspell-2.25.3-43.fc20.i686
gnome-session-xsession-3.9.90-1.fc21.i686
libgnomecups-0.2.3-12.fc18.i686
schroedinger-cat-backgrounds-gnome-18.91.0-2.fc20.noarch
gnome-python2-rsvg-2.32.0-15.fc20.i686
libgnomekbd-3.6.0-3.fc20.i686
gnome-backgrounds-3.9.91-1.fc21.noarch
libgnome-2.32.1-7.fc20.i686
gnome-system-monitor-3.9.90-1.fc21.i686
gnome-python2-gconf-2.28.1-13.fc20.i686
gnome-calculator-3.9.90-1.fc21.i686
gnome-python2-libwnck-2.32.0-15.fc20.i686
gnome-python2-desktop-2.32.0-15.fc20.i686
libgnomeui-2.24.5-7.fc20.i686
gnome-online-miners-3.9.90-1.fc21.i686
gnome-keyring-3.9.90-1.fc21.i686
gnome-python2-2.28.1-13.fc20.i686
nimbus-theme-gnome-0.1.4-8.fc20.noarch
gnome-shell-extension-places-menu-3.9.90-1.fc21.noarch
gnome-settings-daemon-3.9.90-2.fc21.i686
gnome-color-manager-3.8.2-3.fc20.i686
libgnomecanvas-2.30.3-7.fc20.i686
gnome-themes-standard-3.9.90-1.fc21.i686
gnome-dvb-daemon-0.2.10-3.fc20.i686
gnome-vfs2-2.24.4-13.fc20.i686
gnome-disk-utility-3.9.0-1.fc21.i686
gnome-abrt-0.3.0-3.fc20.i686
polkit-gnome-0.105-5.fc20.i686
gnome-video-effects-0.4.0-6.fc20.noarch
gnome-icon-theme-extras-3.6.2-3.fc20.noarch
gnome-boxes-3.9.3-4.fc20.i686
gnome-shell-3.9.90-1.fc21.i686
gnome-screensaver-3.6.1-5.fc20.i686
gnome-js-common-0.1.2-8.fc20.noarch
gnome-keyring-pam-3.9.90-1.fc21.i686
gnome-shell-extension-apps-menu-3.9.90-1.fc21.noarch
desktop-backgrounds-gnome-19.0.0-3.fc20.noarch
gnome-classic-session-3.9.90-1.fc21.noarch
gnome-python2-extras-2.25.3-43.fc20.i686
NetworkManager-pptp-gnome-0.9.8.2-3.fc21.i686
spherical-cow-backgrounds-gnome-18.0.0-3.fc20.noarch
gnome-icon-theme-3.9.5-1.fc20.noarch
gnome-theme-curvylooks-0.4-0.6.rc2.fc20.noarch
gnome-menus-3.8.0-3.fc20.i686
gnome-system-log-3.9.90-1.fc21.i686
gnome-session-3.9.90-1.fc21.i686
gnome-tweak-tool-3.9.90.1-1.fc21.noarch
gnome-settings-daemon-updates-3.9.90-2.fc21.i686
gnome-shell-extension-launch-new-instance-3.9.90-1.fc21.noarch
gnome-icon-theme-symbolic-3.9.5-1.fc20.noarch
libgnome-keyring-3.9.1-2.fc20.i686
gnome-contacts-3.9.90-1.fc21.i686
gnome-bluetooth-libs-3.9.3-4.fc20.i686
gnome-shell-extension-alternate-tab-3.9.90-1.fc21.noarch
NetworkManager-vpnc-gnome-0.9.8.2-2.fc21.i686
gnome-terminal-3.9.90-1.fc20.i686
gnome-doc-utils-stylesheets-0.20.10-5.fc20.noarch
gnome-shell-extension-common-3.9.90-1.fc21.noarch
gnome-themes-2.32.0-11.fc20.noarch
gnome-doc-utils-0.20.10-5.fc20.noarch
gnome-dictionary-3.9.0-1.fc21.i686
Comment 31 Dethlef Madsen 2013-09-04 10:36:40 EDT
Created attachment 793718 [details]
gnome packages build 20130904 - 16:30 CEST

Hello Christopher,

(In reply to Christopher Meng from comment #29)

> [rpmaker@fab ~]$ rpm -qa|grep gnome-shell
> gnome-shell-extension-window-list-3.9.90-1.fc21.noarch
> gnome-shell-extension-user-theme-3.9.90-1.fc21.noarch
> gnome-shell-extension-places-menu-3.9.90-1.fc21.noarch
> gnome-shell-3.9.90-1.fc21.i686
> gnome-shell-extension-apps-menu-3.9.90-1.fc21.noarch
> gnome-shell-extension-launch-new-instance-3.9.90-1.fc21.noarch
> gnome-shell-extension-alternate-tab-3.9.90-1.fc21.noarch
> gnome-shell-extension-common-3.9.90-1.fc21.noarch


Looks like you are using the rawhide repos (fc21). IMO it should fc20 only.

That's my out from my harddisk install.

See attached file.
Comment 32 Kamil Páral 2013-09-06 08:59:43 EDT
GNOME starts OK with F20 Alpha TC4 i386 Live:
mutter-3.9.91-2.fc20.i686
gnome-shell-3.9.91-1.fc20.i686

Thanks, closing.

Note You need to log in before you can comment on or make changes to this bug.