Bug 1002156 - Displays wrong part of desktop with one window in fullscreen
Displays wrong part of desktop with one window in fullscreen
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jonathon Jongsma
Virtualization Bugs
:
Depends On:
Blocks: 1009648 1022769
  Show dependency treegraph
 
Reported: 2013-08-28 10:21 EDT by Tomas Jamrisko
Modified: 2014-10-14 02:29 EDT (History)
12 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Display configuration sometimes used outdated information about the position of the virt-viewer/remote-viewer windows in order to align and configure the guest displays Consequence: Sometimes the guest displays were configured with overlapping regions. Different client windows showed some of the same content. Fix: Always use the current window location to align and configure displays Result: Display configuration works properly and guest displays do not get overlapped.
Story Points: ---
Clone Of:
: 1022769 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:29:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Left display is fullscreen guest, right one is maximized. Notice how left side of the primary display appears in both windows (2.72 MB, image/png)
2013-08-28 10:21 EDT, Tomas Jamrisko
no flags Details

  None (edit)
Description Tomas Jamrisko 2013-08-28 10:21:26 EDT
Created attachment 791413 [details]
Left display is fullscreen guest, right one is maximized. Notice how left side of the primary display appears in both windows

Description of problem:
Opening two monitors on a dual head setup and switching one of them to fullscreen can result in its corruption -- displaying parts of the other window

Version-Release number of selected component (if applicable):
spice-gtk-0.20-5.el6.x86_64
virt-viewer-0.5.6-7.el6.x86_64
spice-vdagent-0.14.0-1.el6.x86_64.rpm

How reproducible:
Fairly often

Steps to Reproduce:
1. Get dual head client with different resolutions of windows
2. Open two displays on guest (have position of primary displays swapped between client and guest)
3. Switch the one on secondary display of client to fullscreen

Actual results:
See screenshot
Comment 2 RHEL Product and Program Management 2013-10-13 22:30:47 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 CongDong 2013-10-23 21:48:05 EDT
I can reproduce with:
virt-viewer-0.5.6-8.el6.x86_64

1. Get dual head client with different resolutions of windows
2. Open two displays with full screen.
3. Click leave screen on the primary display, then change it to fullscreen again.

Result:
The primary display will cover part of the other display.And check the "Display Preferences", one display overlaps other one.
Comment 4 Jonathon Jongsma 2013-11-27 14:22:01 EST
I've pushed several patches upstream that should fix this particular issue.
Comment 6 Marc-Andre Lureau 2014-06-03 10:19:12 EDT
Jonathon, please update bug status, fill the Doc Text. thanks
Comment 8 CongDong 2014-06-09 02:23:31 EDT
I can reproduce with:
virt-viewer-0.5.6-8.el6.x86_64


Verify with virt-viewer-0.6.0-5.el6.x86_64
1. Get dual head client with different resolutions of windows
2. Open two displays on guest (have position of primary displays swapped between client and guest)
3. Switch the one on secondary display of client to fullscreen

Result:
two displays have no overlap.

Also test as comment 3. Result is expected, two displays have no overlap.

As the result, VERIFIED this bug.
Comment 9 errata-xmlrpc 2014-10-14 02:29:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html

Note You need to log in before you can comment on or make changes to this bug.