This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1022769 - Displays wrong part of desktop with one window in fullscreen
Displays wrong part of desktop with one window in fullscreen
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jonathon Jongsma
Virtualization Bugs
:
Depends On: 1002156
Blocks: 1009648
  Show dependency treegraph
 
Reported: 2013-10-23 21:51 EDT by CongDong
Modified: 2014-06-18 00:29 EDT (History)
12 users (show)

See Also:
Fixed In Version: 0.5.7-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1002156
Environment:
Last Closed: 2014-06-13 08:26:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Jonathon Jongsma 2013-11-27 14:25:36 EST
fix applied upstream.
Comment 3 David Blechter 2013-12-13 11:38:08 EST
t
Comment 4 CongDong 2013-12-18 05:11:50 EST
I can reproduce this on RHEL7 with:
virt-viewer-0.5.7-2.el7.x86_64

Steps:
1. prepare a spice guest with qxl and spicevmc
2. connect the guest with virt-viewer and open two displays
3. move display 1 to the non-primary physical monitor and Maximize it.
   move display 2 to the primary physical monitor and fullscreen it(F11).
4. make display 2 leave fullscreen, and change to fullscreen again.

Result:
the two displays will display the wrong parts as the description said.
looks like the two displays have a overlap.

Verify it with:
virt-viewer-0.5.7-3.el7.x86_64

Steps:
As the steps above.

Result:
There two displays have no overlaps and virt-viewer works well.

As the result, change to VERIFIED.
Comment 5 Ludek Smid 2014-06-13 08:26:16 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.