Bug 1002286 - Disable or remove device isa-parallel
Disable or remove device isa-parallel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
Depends On:
Blocks: 720747
  Show dependency treegraph
 
Reported: 2013-08-28 15:32 EDT by Markus Armbruster
Modified: 2014-06-17 23:35 EDT (History)
7 users (show)

See Also:
Fixed In Version: qemu-kvm-1.5.3-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:03:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Armbruster 2013-08-28 15:32:18 EDT
Device isa-parallel should be removed or made unavailable with -device / device_add, because we won't support it.

How reproducible:
Always

Steps to Reproduce:
1. -chardev null,id=par0 -device isa-parallel,chardev=par0

Actual results:
-device isa-parallel is accepted

Expected results:
-device isa-parallel is rejected, just like -device nonexistant

Additional info:
Disabling CONFIG_PARALLEL should do.
Comment 2 Miroslav Rezanina 2013-09-26 05:33:09 EDT
Fix included in qemu-kvm-1.5.3-7.el7
Comment 4 Jun Li 2013-12-12 02:20:18 EST
Verify this bug:
Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-21.el7.x86_64
---
# /usr/libexec/qemu-kvm -device ? 2>&1 |grep -i isa-parallel
---
# /usr/libexec/qemu-kvm -device isa-parallel,?
qemu-kvm: -device isa-parallel,?: Parameter 'driver' expects device type
---
Base on above test, this bug has been verified.
Comment 5 Jun Li 2013-12-12 03:46:47 EST
Test with qemu-kvm-1.5.3-21.el7.x86_64 got the same results as comments 4.
Comment 7 Ludek Smid 2014-06-13 06:03:38 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.