Bug 1002351 - [abrt] WARNING: at lib/list_debug.c:53 __list_del_entry+0x60/0xe0()
[abrt] WARNING: at lib/list_debug.c:53 __list_del_entry+0x60/0xe0()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
abrt_hash:7b1a9fca4b1bf4b8ef702a2ab16...
:
: 989482 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 21:20 EDT by Andy
Modified: 2013-09-22 20:35 EDT (History)
10 users (show)

See Also:
Fixed In Version: kernel-3.11.1-300.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-22 20:35:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (64.79 KB, text/plain)
2013-08-28 21:21 EDT, Andy
no flags Details

  None (edit)
Description Andy 2013-08-28 21:20:57 EDT
Description of problem:
Normal circumstances. I powered my laptop, logged in normally, and once the session was completely loaded, I noticed de icon indicating a bug.

Additional info:
reporter:       libreport-2.1.5
WARNING: at lib/list_debug.c:53 __list_del_entry+0x60/0xe0()
list_del corruption, f5a8f900->next is LIST_POISON1 (00100100)
device-mapper: ioctl: error adding target to table
Modules linked in: dm_crypt i915 i2c_algo_bit drm_kms_helper drm r8169 mii i2c_core video ums_realtek usb_storage sunrpc
CPU: 1 PID: 248 Comm: systemd-cryptse Not tainted 3.10.4-100.fc18.i686 #1
Hardware name: TOSHIBA TOSHIBA NB305/NPVAA, BIOS V1.70 06/03/2010
 f5ad9ba8 f5ad9ba8 f5ad9b70 c098939f f5ad9b98 c043e9f4 c0b4bbf0 f5ad9bc4
 00000035 c068bc00 c068bc00 f5a8f900 fffffffe 00000004 f5ad9bb0 c043eab3
 00000009 f5ad9ba8 c0b4bbf0 f5ad9bc4 f5ad9bd0 c068bc00 c0b4b117 00000035
Call Trace:
 [<c098939f>] dump_stack+0x16/0x18
 [<c043e9f4>] warn_slowpath_common+0x64/0x80
 [<c068bc00>] ? __list_del_entry+0x60/0xe0
 [<c068bc00>] ? __list_del_entry+0x60/0xe0
 [<c043eab3>] warn_slowpath_fmt+0x33/0x40
 [<c068bc00>] __list_del_entry+0x60/0xe0
 [<c068bc8b>] list_del+0xb/0x20
 [<c063a48c>] crypto_larval_kill+0x1c/0x50
 [<c063abdd>] crypto_alg_mod_lookup+0x5d/0x80
 [<c063dc56>] crypto_lookup_skcipher+0x26/0x310
 [<c0513b56>] ? pcpu_next_pop+0x36/0x50
 [<c0514db4>] ? pcpu_alloc+0x754/0x830
 [<c068010f>] ? string.isra.4+0x2f/0xa0
 [<c068172a>] ? vsnprintf+0x2ca/0x3d0
 [<c0537e77>] ? __kmalloc+0x47/0x230
 [<c063df82>] crypto_alloc_ablkcipher+0x42/0xa0
 [<f7cac18f>] crypt_ctr+0x24f/0x830 [dm_crypt]
 [<c0845d66>] dm_table_add_target+0x176/0x3f0
 [<c08451ce>] ? alloc_targets+0x6e/0xd0
 [<c0848a9b>] table_load+0xeb/0x2f0
 [<c08493f7>] ctl_ioctl+0x227/0x440
 [<c0475861>] ? enqueue_entity+0x281/0x8e0
 [<c08489b0>] ? list_devices+0x150/0x150
 [<c0575880>] ? bdput+0x10/0x20
 [<c0849610>] ? ctl_ioctl+0x440/0x440
 [<c0849621>] dm_ctl_ioctl+0x11/0x20
 [<c0556077>] do_vfs_ioctl+0x77/0x590
 [<c0620f8a>] ? inode_has_perm.isra.33.constprop.64+0x3a/0x50
 [<c0622628>] ? file_has_perm+0x98/0xb0
 [<c0622a28>] ? selinux_file_ioctl+0x48/0xe0
 [<c0556608>] SyS_ioctl+0x78/0x90
 [<c0995c8d>] sysenter_do_call+0x12/0x28

Potential duplicate: bug 989482
Comment 1 Andy 2013-08-28 21:21:04 EDT
Created attachment 791558 [details]
File: dmesg
Comment 2 Neil Horman 2013-08-29 09:31:25 EDT
looks like we might not be locking the crypto_alg_sem in crypto_remove_final.  Can you reproduce this issue?
Comment 3 Andy 2013-09-02 14:25:00 EDT
No, I haven't been able to reproduce it.
Comment 4 Neil Horman 2013-09-02 14:36:50 EDT
hmm, well I'll try to work up a patch based on code observation for you to test with anyway.  Won't hurt to try.
Comment 5 Neil Horman 2013-09-07 10:20:22 EDT
https://lkml.org/lkml/2013/9/6/454
Comment 7 Josh Boyer 2013-09-11 10:31:34 EDT
*** Bug 989482 has been marked as a duplicate of this bug. ***
Comment 8 Josh Boyer 2013-09-11 10:32:11 EDT
CC'd to stable, so it should get picked up shortly.
Comment 9 Fedora Update System 2013-09-14 18:31:21 EDT
kernel-3.11.1-300.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.11.1-300.fc20
Comment 10 Fedora Update System 2013-09-15 13:37:27 EDT
Package kernel-3.11.1-300.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.11.1-300.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16794/kernel-3.11.1-300.fc20
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-09-22 20:35:18 EDT
kernel-3.11.1-300.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.