Bug 1002517 - Header files are unusable due to referencing non-existant ws_symbol_export.h file
Header files are unusable due to referencing non-existant ws_symbol_export.h ...
Status: CLOSED DUPLICATE of bug 981366
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 07:29 EDT by Daniel Berrange
Modified: 2016-05-31 21:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 11:11:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2013-08-29 07:29:09 EDT
Description of problem:
The header files in wireshark-devel reference a file 'ws_symbol_export.h' eg see

$ grep -r  ws_symbol_export.h /usr/include/wireshark/
/usr/include/wireshark/register.h:#include "ws_symbol_export.h"
/usr/include/wireshark/wiretap/daintree-sna.h:#include "ws_symbol_export.h"
/usr/include/wireshark/wiretap/tnef.h:#include "ws_symbol_export.h"
/usr/include/wireshark/wiretap/hcidump.h:#include "ws_symbol_export.h"
/usr/include/wireshark/wiretap/snoop.h:#include "ws_symbol_export.h"
/usr/include/wireshark/wiretap/dbs-etherwatch.h:#include "ws_symbol_export.h"
/usr/include/wireshark/wiretap/cosine.h:#include "ws_symbol_export.h"
/usr/include/wireshark/wiretap/eyesdn.h:#include "ws_symbol_export.h"
/usr/include/wireshark/wiretap/buffer.h:#include "ws_symbol_export.h"
/usr/include/wireshark/wiretap/i4btrace.h:#include "ws_symbol_export.h"
/usr/include/wireshark/wiretap/dct3trace.h:#include "ws_symbol_export.h"
/usr/include/wireshark/wiretap/btsnoop.h:#include "ws_symbol_export.h"
...snip...

This header file does not exist anywhere though

 $ find /usr/include/ | grep ws_symbol_export.h
 $  rpm -ql wireshark-devel | grep ws_symbol_export.h
 $

These broken headers make it impossible to compile the libvirt wireshark dissector plugin

Version-Release number of selected component (if applicable):
wireshark-devel-1.10.0-2.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Try to compile a wireshark dissector using wireshark-devel headers
2.
3.

Actual results:
Fail on non-existant  ws_symbol_export.h header

Expected results:


Additional info:
Comment 1 Daniel Berrange 2013-08-29 07:46:24 EDT
Looks like ws_symbol_export.h is a new file in the version of wireshark on F19 and the RPM is not copying it to the include dir.
Comment 2 Daniel Berrange 2013-08-29 07:51:12 EDT
The following change to F19 wireshark.spec fixes the headers

@@ -243,6 +243,7 @@ install -m 644 epan/dfilter/*.h                     "${IDIR}/epan/dfilter"
 install -m 644 epan/dissectors/*.h             "${IDIR}/epan/dissectors"
 install -m 644 wiretap/*.h                     "${IDIR}/wiretap"
 install -m 644 wsutil/*.h                      "${IDIR}/wsutil"
+install -m 644 ws_symbol_export.h              "${IDIR}/"
 
 #      Create pkg-config control file.
 mkdir -p "${RPM_BUILD_ROOT}%{_libdir}/pkgconfig"
Comment 3 Peter Hatina 2013-09-05 11:11:47 EDT

*** This bug has been marked as a duplicate of bug 981366 ***

Note You need to log in before you can comment on or make changes to this bug.