Bug 981366 - [patch] include ws_symbol_export.h in wireshark-devel
[patch] include ws_symbol_export.h in wireshark-devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
19
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
:
: 1002517 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 10:36 EDT by Christof Efkemann
Modified: 2016-05-31 21:31 EDT (History)
5 users (show)

See Also:
Fixed In Version: wireshark-1.10.2-4.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 19:54:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for Wireshark spec file: include ws_symbol_export.h in wireshark-devel (522 bytes, patch)
2013-07-04 10:36 EDT, Christof Efkemann
no flags Details | Diff

  None (edit)
Description Christof Efkemann 2013-07-04 10:36:05 EDT
Created attachment 768841 [details]
patch for Wireshark spec file: include ws_symbol_export.h in wireshark-devel

Description of problem:
wireshark-devel RPM does not include the header file ws_symbol_export.h, which is #included from most other Wireshark header files. Building Wireshark plug-ins is not possible without it.

Version-Release number of selected component (if applicable):
1.10.0-2

How reproducible:
always

Steps to Reproduce:
1. yum install wireshark-devel
2. Include Wireshark header file (like <epan/packet.h>) in your own C file.
3. Try to compile your C file.


Actual results:
/usr/include/wireshark/wiretap/wtap.h:32:30: fatal error: ws_symbol_export.h: No such file or directory

Expected results:
No errors.

Additional info:
Comment 1 Fedora Update System 2013-09-05 06:15:43 EDT
wireshark-1.10.0-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wireshark-1.10.0-5.fc19
Comment 2 Fedora Update System 2013-09-05 06:15:52 EDT
wireshark-1.10.0-11.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wireshark-1.10.0-11.fc20
Comment 3 Peter Hatina 2013-09-05 11:11:47 EDT
*** Bug 1002517 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2013-09-05 13:54:08 EDT
Package wireshark-1.10.0-11.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wireshark-1.10.0-11.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15873/wireshark-1.10.0-11.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-09 19:54:15 EDT
wireshark-1.10.0-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-09-10 07:11:05 EDT
wireshark-1.10.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wireshark-1.10.1-1.fc20
Comment 7 Fedora Update System 2013-09-11 08:01:08 EDT
wireshark-1.10.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wireshark-1.10.2-1.fc20
Comment 8 Fedora Update System 2013-09-11 08:02:30 EDT
wireshark-1.10.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wireshark-1.10.2-1.fc19
Comment 9 Fedora Update System 2013-09-12 03:53:40 EDT
wireshark-1.10.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wireshark-1.10.2-2.fc20
Comment 10 Fedora Update System 2013-09-12 03:54:31 EDT
wireshark-1.10.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wireshark-1.10.2-2.fc19
Comment 11 Fedora Update System 2013-09-12 12:48:06 EDT
wireshark-1.10.2-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wireshark-1.10.2-4.fc19
Comment 12 Fedora Update System 2013-09-12 12:49:09 EDT
wireshark-1.10.2-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wireshark-1.10.2-4.fc20
Comment 13 Fedora Update System 2013-09-13 10:02:11 EDT
wireshark-1.10.2-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wireshark-1.10.2-5.fc20
Comment 14 Fedora Update System 2013-09-13 10:03:31 EDT
wireshark-1.10.2-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wireshark-1.10.2-5.fc19
Comment 15 Fedora Update System 2013-09-16 20:26:56 EDT
wireshark-1.10.2-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-09-24 15:33:32 EDT
wireshark-1.10.2-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wireshark-1.10.2-6.fc19
Comment 17 Fedora Update System 2013-09-24 15:35:51 EDT
wireshark-1.10.2-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/wireshark-1.10.2-4.fc18
Comment 18 Fedora Update System 2013-09-24 15:38:10 EDT
wireshark-1.10.2-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wireshark-1.10.2-7.fc20
Comment 19 Fedora Update System 2013-09-27 20:09:34 EDT
wireshark-1.10.2-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-10-02 21:02:15 EDT
wireshark-1.10.2-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2013-12-19 02:08:59 EST
wireshark-1.10.2-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.