Bug 1002578 - atomic_cas32 doesn't work on ppc
atomic_cas32 doesn't work on ppc
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
20
ppc64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1001203 1128127 1206133
  Show dependency treegraph
 
Reported: 2013-08-29 09:20 EDT by Jaroslav Škarvada
Modified: 2016-01-18 04:31 EST (History)
5 users (show)

See Also:
Fixed In Version: boost-1.53.0-14.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1128127 1206133 (view as bug list)
Environment:
Last Closed: 2013-09-07 20:35:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (256 bytes, text/plain)
2013-08-29 09:20 EDT, Jaroslav Škarvada
no flags Details
Proposed fix (700 bytes, patch)
2013-08-29 09:21 EDT, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Jaroslav Škarvada 2013-08-29 09:20:15 EDT
Created attachment 791798 [details]
Reproducer

Description of problem:
atomic_cas32 doesn't work on ppc

Version-Release number of selected component (if applicable):
boost-devel-1.54.0-2.fc20.ppc

How reproducible:
Always

Steps to Reproduce:
1. Compile and run the attached reproducer

Actual results:
2

Expected results:
0

Additional info:
This breaks IPC and can cause never-ending loops, etc., for example see bug 1001203.
Comment 1 Jaroslav Škarvada 2013-08-29 09:21:17 EDT
Created attachment 791799 [details]
Proposed fix

It seems like typo in the ASM. The 1.53 seems to be also affected.
Comment 2 Jaroslav Škarvada 2013-08-29 09:27:53 EDT
Decreasing the version to f20.
Comment 3 Petr Machata 2013-08-29 18:25:52 EDT
Filed upstream as https://svn.boost.org/trac/boost/ticket/9065
I think a better fix is simply swapping the incoming arguments of the inline assembly block, as that way they match the incoming arguments of the function itself.  That's what I'll apply in F 19+.
Comment 4 Fedora Update System 2013-09-02 05:34:23 EDT
boost-1.53.0-14.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/boost-1.53.0-14.fc19
Comment 5 Petr Machata 2013-09-02 05:40:02 EDT
Note that I have added the fix to F20 and Rawhide as well.
Comment 6 Fedora Update System 2013-09-02 19:25:53 EDT
Package boost-1.53.0-14.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing boost-1.53.0-14.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15639/boost-1.53.0-14.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-09-07 20:35:22 EDT
boost-1.53.0-14.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.