Bug 1128127 - atomic_cas32 doesn't work on ppc
Summary: atomic_cas32 doesn't work on ppc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: boost
Version: 7.0
Hardware: ppc64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Machata
QA Contact: Miloš Prchlík
URL:
Whiteboard:
Depends On: 1002578
Blocks: 1001203
TreeView+ depends on / blocked
 
Reported: 2014-08-08 10:50 UTC by Jaroslav Škarvada
Modified: 2015-03-05 08:19 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1002578
Environment:
Last Closed: 2015-03-05 08:19:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0348 normal SHIPPED_LIVE boost bug fix update 2015-03-05 12:39:40 UTC

Description Jaroslav Škarvada 2014-08-08 10:50:52 UTC
+++ This bug was initially created as a clone of Bug #1002578 +++

Description of problem:
atomic_cas32 doesn't work on ppc

Version-Release number of selected component (if applicable):
boost-devel-1.54.0-2.fc20.ppc

How reproducible:
Always

Steps to Reproduce:
1. Compile and run the attached reproducer

Actual results:
2

Expected results:
0

Additional info:
This breaks IPC and can cause never-ending loops, etc., for example see bug 1001203.

--- Additional comment from Jaroslav Škarvada on 2013-08-29 15:21:17 CEST ---

It seems like typo in the ASM. The 1.53 seems to be also affected.

--- Additional comment from Jaroslav Škarvada on 2013-08-29 15:27:53 CEST ---

Decreasing the version to f20.

--- Additional comment from Petr Machata on 2013-08-30 00:25:52 CEST ---

Filed upstream as https://svn.boost.org/trac/boost/ticket/9065
I think a better fix is simply swapping the incoming arguments of the inline assembly block, as that way they match the incoming arguments of the function itself.  That's what I'll apply in F 19+.

--- Additional comment from Fedora Update System on 2013-09-02 11:34:23 CEST ---

boost-1.53.0-14.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/boost-1.53.0-14.fc19

--- Additional comment from Petr Machata on 2013-09-02 11:40:02 CEST ---

Note that I have added the fix to F20 and Rawhide as well.

--- Additional comment from Fedora Update System on 2013-09-03 01:25:53 CEST ---

Package boost-1.53.0-14.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing boost-1.53.0-14.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15639/boost-1.53.0-14.fc19
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2013-09-08 02:35:22 CEST ---

boost-1.53.0-14.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 1 Jaroslav Škarvada 2014-08-08 10:51:53 UTC
Currently blocking some epel-7 packages.

Comment 8 Miloš Prchlík 2014-12-01 13:14:32 UTC
Verified for build boost-1.53.0-23.el7.

Comment 10 errata-xmlrpc 2015-03-05 08:19:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0348.html


Note You need to log in before you can comment on or make changes to this bug.