Bug 1002697 - Mouse pointer appears black on PuTTY terminals opened from windows 7 guests [mingw-virt-viewer]
Mouse pointer appears black on PuTTY terminals opened from windows 7 guests [...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.3.0
Assigned To: Marc-Andre Lureau
Desktop QE
:
: 1017301 (view as bug list)
Depends On: 998529
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-08-29 13:58 EDT by Bryan Yount
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version: mingw-virt-viewer-0.5.6-9.el6_4
Doc Type: Bug Fix
Doc Text:
When running a mouse over a PuTTY session with Windows guests, the mouse pointer appears "black". This update improves the cursor contrast, so the cursor is visible on PuTTY sessions with Windows guests.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:46:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 466483 None None None Never

  None (edit)
Description Bryan Yount 2013-08-29 13:58:39 EDT
*Note:* Copied from Bug 998529 and opened against the Windows version of virt-viewer, called mingw-virt-viewer.


Description of problem:
On PuTTY sessions the mouse pointer appears black when opened from a windows 7 guest connected via spice.

the issue is described more deeply here: 
http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/black-pointer.html

and arises also when connecting via rdesktop (see http://osdir.com/ml/network.rdesktop.user/2005-03/msg00012.html) but it does not arise when connecting via MSTSC or via freeRDP.

Workaround:

     The I-beam mouse pointer that PuTTY uses is not rendered the same in rdesktop as it is in the Windows Remote Desktop client. The workaround is to change the "Text Select" pointer on the Windows machine by going to Control Panel->Mouse->Pointers. I changed it to the beam_r.cur image, which is a beefier version of the I-beam bitmap which does render nicely in rdesktop. 


Version-Release number of selected component (if applicable):
   All versions

How reproducible:
   100%

Steps to Reproduce:
1. open putty terminal in in Win7 guest accessed cia spice

Actual results:
   Cursor is black

Expected results:
   Cursor is white
Comment 2 Marc-Andre Lureau 2013-09-12 07:09:10 EDT
(the bug is in post assuming Alon fixes work on windows too, we are missing acks to get this in the msi build)
Comment 4 Tomas Jamrisko 2013-10-10 08:12:54 EDT
*** Bug 1017301 has been marked as a duplicate of this bug. ***
Comment 6 Uri Lublin 2013-10-24 17:23:35 EDT
A fix is pushed upstream -- commit 11ddba4b09bc2e3024cfd1c9f0d78948d004bb40
Comment 8 Charlie 2013-11-27 20:27:03 EST
This bug is currently attached to errata RHEA-2013:15512. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 09:46:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0034.html

Note You need to log in before you can comment on or make changes to this bug.