Bug 1017301 - Cursor is invisible over input fields on windows 8 client
Cursor is invisible over input fields on windows 8 client
Status: CLOSED DUPLICATE of bug 1002697
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 11:20 EDT by Tomas Jamrisko
Modified: 2013-10-10 08:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 08:12:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2013-10-09 11:20:39 EDT
Description of problem:
The cursor becomes invisible instead of changing shape when hovering over input fields (windows 8 client, windows guest) 

Version-Release number of selected component (if applicable):
mingw-virt-viewer-0.5.6-6

How reproducible:
Always 

Steps to Reproduce:
1. connect to a windows guest
2. Open notepad/anything that is supposed to have text input
3. Position your cursor over it

Actual results:
The cursor becomes invisible

Expected results:
it should change shape to the "I"

Additional info:
Works well on other clients (both RHEL and Windows)
Comment 1 Marc-Andre Lureau 2013-10-09 11:27:12 EDT
client doesn't provide any warning? Can you get the SPICE_DEBUG=1 log please.
Comment 2 Tomas Jamrisko 2013-10-09 11:34:17 EDT
only the warning about automount-inhibiting implementation not available. 
There's nothing else on cmd nor in event log
Comment 3 Marc-Andre Lureau 2013-10-09 11:39:45 EDT
ah, then this is likely going to be a gtk+ bug on win8. It would be surprising that noone else hit that.
Comment 4 Tomas Jamrisko 2013-10-09 11:47:07 EDT
Well, it changes over URL input field before any connection actually takes place...
Comment 5 Marc-Andre Lureau 2013-10-09 11:52:04 EDT
(In reply to Tomas Jamrisko from comment #4)
> Well, it changes over URL input field before any connection actually takes
> place...

yeah, but that's a local gtk+ or local windows cursor.

I guess the customer cursor path could be broken.
Comment 6 Tomas Jamrisko 2013-10-10 04:17:58 EDT
So, it's not really invisible, it appears that way on white background.
It's actually ocmposed of white and transparent pixels only. Each line one pixel wide.

Anyway started it wit --spice-debug and:

(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:354 cursor-4:0: set_cursor: flags 4, size 0
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:360 cursor-4:0: set_cursor: type 1, 3, 32x32
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:354 cursor-4:0: set_cursor: flags 4, size 0
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:360 cursor-4:0: set_cursor: type 1, 2, 32x32
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:354 cursor-4:0: set_cursor: flags 4, size 0
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:360 cursor-4:0: set_cursor: type 1, 3, 32x32
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:354 cursor-4:0: set_cursor: flags 4, size 0
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:360 cursor-4:0: set_cursor: type 1, 2, 32x32
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:354 cursor-4:0: set_cursor: flags 4, size 0
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:360 cursor-4:0: set_cursor: type 1, 3, 32x32
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:354 cursor-4:0: set_cursor: flags 4, size 0
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:360 cursor-4:0: set_cursor: type 1, 2, 32x32
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:354 cursor-4:0: set_cursor: flags 4, size 0
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:360 cursor-4:0: set_cursor: type 1, 3, 32x32
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:354 cursor-4:0: set_cursor: flags 4, size 0
(remote-viewer.exe:1812): GSpice-DEBUG: ../../gtk/channel-cursor.c:360 cursor-4:0: set_cursor: type 1, 2, 32x32
Comment 7 Marc-Andre Lureau 2013-10-10 07:23:32 EDT
That is probably related to the putty change in 998529.

What happen with previous release of mingw-virt-viewer?
Comment 8 Tomas Jamrisko 2013-10-10 07:42:20 EDT
Works with 0.5.6-5, so looks like you're right.
Comment 9 Marc-Andre Lureau 2013-10-10 07:58:33 EDT
I propose closing as duplicate of 1002697, and reopening there. Perhaps we should revert the change?

I guess the issue happens not only with win8 clients.
Comment 10 Tomas Jamrisko 2013-10-10 08:12:54 EDT

*** This bug has been marked as a duplicate of bug 1002697 ***
Comment 11 Marc-Andre Lureau 2013-10-10 08:29:21 EDT
Tomas, is it really only with win8 client?
Comment 12 Tomas Jamrisko 2013-10-10 08:42:33 EDT
I wasn't sure about Windows 7 as I had only a VM as client, but tried in on a physical client and the Cursor appeared white and dotted as well. So it's not windows 8 exclusive -> It happens on all of them.

Note You need to log in before you can comment on or make changes to this bug.