Bug 1002726 - Unable to select the menu items if my logo-header is hidden in my web page
Unable to select the menu items if my logo-header is hidden in my web page
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tom McKay
sthirugn@redhat.com
:
Depends On:
Blocks: sam13-tracker 1003110
  Show dependency treegraph
 
Reported: 2013-08-29 15:39 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1003110 (view as bug list)
Environment:
Last Closed: 2013-10-01 07:22:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
web page with logo header (37.12 KB, image/png)
2013-08-29 15:40 EDT, sthirugn@redhat.com
no flags Details
web page with logo header hidden by scrolling (32.01 KB, image/png)
2013-08-29 15:41 EDT, sthirugn@redhat.com
no flags Details

  None (edit)
Description sthirugn@redhat.com 2013-08-29 15:39:24 EDT
Description of problem:
Unable to select the menu items if my logo-header is hidden in my web page

Version-Release number of selected component (if applicable):
* candlepin-0.8.24-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.24-1.el6sam.noarch
* candlepin-tomcat6-0.8.24-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-9.el6sat.noarch
* katello-cli-common-1.4.3-9.el6sat.noarch
* katello-common-1.4.3-11.el6sam_splice.noarch
* katello-configure-1.4.4-3.el6sat.noarch
* katello-glue-candlepin-1.4.3-11.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-11.el6sam_splice.noarch
* katello-headpin-1.4.3-11.el6sam_splice.noarch
* katello-headpin-all-1.4.3-11.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch

How reproducible:
Always

Steps to Reproduce:
1. Log in to SAM UI
2. Keep the logo header visible (Attached Screenshot 1)
3. Navigate to Subscriptions -> Red Hat Subscriptions -> Works fine. No complaints.
4. Keep the logo header hidden by scrolling the web page down (Attached Screenshot 2)
5. Attempt to click a menu item like Subscriptions -> Red Hat Subscriptions or Systems -> All.

Actual results:
I am not able to click the menu items as explained in Step 5 above.  The menu disappears even before I click those items.

Expected results:
The menu items should be clickable.

Additional info:
Comment 1 sthirugn@redhat.com 2013-08-29 15:40:35 EDT
Created attachment 791943 [details]
web page with logo header
Comment 2 sthirugn@redhat.com 2013-08-29 15:41:29 EDT
Created attachment 791945 [details]
web page with logo header hidden by scrolling
Comment 3 Tom McKay 2013-08-30 16:00:25 EDT
Two short term workarounds possible:
https://gist.github.com/waldenraines/634606670fd3a380a394
https://gist.github.com/waldenraines/1f593875eca89efb3716

I will apply one to internal product repo, leaving the Sat6 clone open for real fixing.
Comment 5 sthirugn@redhat.com 2013-09-05 16:31:17 EDT
Verified.  But found an other minor Bug #1004593 while verifiying this issue.

Version Tested.
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-10.el6sat.noarch
* katello-cli-common-1.4.3-10.el6sat.noarch
* katello-common-1.4.3-12.el6sam_splice.noarch
* katello-configure-1.4.4-4.el6sat.noarch
* katello-glue-candlepin-1.4.3-12.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-12.el6sam_splice.noarch
* katello-headpin-1.4.3-12.el6sam_splice.noarch
* katello-headpin-all-1.4.3-12.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.34-1.el6sam.noarch
* thumbslug-selinux-0.0.34-1.el6sam.noarch
Comment 7 errata-xmlrpc 2013-10-01 07:22:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.