Bug 1003000 - [RFE] after installation http://<fqdn>/ is not redirected to http://<fqdn>/sam
[RFE] after installation http://<fqdn>/ is not redirected to http://<fqdn>/sam
Status: CLOSED DUPLICATE of bug 805265
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 08:51 EDT by Jan Hutař
Modified: 2013-08-30 12:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 12:10:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-08-30 08:51:37 EDT
Description of problem:
I have just installed SAM 1.3 Snap4, configured it and the attempted to access it's webUI. I have failed because I have not added ".../sam" to the URL.


Version-Release number of selected component (if applicable):
katello-headpin-all-1.4.3-11.el6sam_splice.noarch


How reproducible:
always


Steps to Reproduce:
1. # yum install -y katello-headpin-all
2. # katello-configure --deployment=sam --user-pass=admin
3. Direct your browser to http://<fqdn>


Actual results:
Default Apache page is displayed


Expected results:
You should be redirected to https://<fqdn>/sam/
Comment 1 Tom McKay 2013-08-30 09:08:31 EDT
This is expected behavior: The suffix /sam must be included.
Comment 2 Jan Hutař 2013-08-30 11:39:43 EDT
As I do not consider this user friendly, would it be at least possible to get katello-configure print as a last line something like:

[...]
Now SAM is prepared for you on: https://<fqdn>/sam

? Thanks in advance.
Comment 3 sthirugn@redhat.com 2013-08-30 11:43:13 EDT
this needs a fix in katello. Moving the bug back to Satellite 6
Comment 4 sthirugn@redhat.com 2013-08-30 12:10:27 EDT
@Jan: We have a bug 805265 already open for your request in Comment 2. Thank you!

*** This bug has been marked as a duplicate of bug 805265 ***

Note You need to log in before you can comment on or make changes to this bug.