Bug 1003034 - hadoop not installable due to file conflicts
hadoop not installable due to file conflicts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hadoop (Show other bugs)
20
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Robert Rati
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 998521 1008201 1008202
  Show dependency treegraph
 
Reported: 2013-08-30 10:16 EDT by Mattias Ellert
Modified: 2013-10-15 02:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: hadoop-2.0.5-12.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 02:33:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2013-08-30 10:16:58 EDT
Description of problem:

Installing hadoop fails due to a file conflict with Qt:

Transaction check error:
  file /usr/bin/rcc from install of hadoop-common-2.0.5-8.fc21.noarch conflicts with file from package qt-devel-1:4.8.5-7.fc21.x86_64

Version-Release number of selected component (if applicable):

# repoquery --whatprovides /usr/bin/rcc
hadoop-common-0:2.0.5-8.fc21.noarch
qt-devel-1:4.8.5-7.fc21.x86_64
qt-devel-1:4.8.5-7.fc21.i686

How reproducible:
Always

Steps to Reproduce:
1. yum install qt-devel
2. yum install hadoop-common

Actual results:

Inatallation fails due to file conflict

Expected results:

Successful installation
Comment 1 Fedora Update System 2013-09-13 12:24:24 EDT
hadoop-2.0.5-9.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hadoop-2.0.5-9.fc20
Comment 2 Fedora Update System 2013-09-13 13:28:52 EDT
Package hadoop-2.0.5-9.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hadoop-2.0.5-9.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16648/hadoop-2.0.5-9.fc20
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-10-03 13:31:40 EDT
hadoop-2.0.5-10.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hadoop-2.0.5-10.fc20
Comment 4 Fedora Update System 2013-10-07 16:03:50 EDT
hadoop-2.0.5-11.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hadoop-2.0.5-11.fc20
Comment 5 Fedora Update System 2013-10-10 18:11:44 EDT
hadoop-2.0.5-12.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hadoop-2.0.5-12.fc20
Comment 6 Fedora Update System 2013-10-15 02:33:33 EDT
hadoop-2.0.5-12.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.