Bug 998521 - Apache Hadoop 2.x [NEEDINFO]
Apache Hadoop 2.x
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
: Tracking
Depends On: 985087 1003034 1005724 1017850
Blocks: 1008201 1008202
  Show dependency treegraph
 
Reported: 2013-08-19 09:26 EDT by Jaroslav Reznik
Modified: 2013-12-18 19:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1008201 1008202 (view as bug list)
Environment:
Last Closed: 2013-12-18 09:01:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
znmeb: needinfo?


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2013-08-19 09:26:46 EDT
This is a tracking bug for Change: Apache Hadoop 2.x
For more details, see: http://fedoraproject.org//wiki/Changes/Hadoop

Provide native Apache Hadoop packages.
Comment 1 Jaroslav Reznik 2013-10-11 04:45:43 EDT
This message is a reminder that Fedora 20 Accepted Changes 100%
Completed Deadline is on 2013-10-15 [1].

All Accepted Changes has to be code complete and ready to be
validated in the Beta release (optionally by Fedora QA). Required
bug state at this point is ON_QA.

As for several System Wide Changes, Beta Change Deadline is a
point of contingency plan, all incomplete Changes will be 
reported to FESCo for 2013-10-16 meeting. In case of any
questions, don't hesitate to ask Wrangler (jreznik).

[1] https://fedoraproject.org/wiki/Releases/20/Schedule
Comment 2 Jaroslav Reznik 2013-10-22 05:21:29 EDT
Moving to ON_QA as agreed with the Owner.
Comment 3 Jaroslav Reznik 2013-12-18 09:01:08 EST
Closing this bug as this Change was delivered in Fedora 20 release. Please, reopen in case of any issues you encounter regarding this Change completion.
Comment 4 M. Edward (Ed) Borasky 2013-12-18 19:45:18 EST
I'm having trouble setting this up using the instructions on the wiki.

https://fedoraproject.org/wiki/Changes/Hadoop 

Is there a current setup procedure that works? The error is

sudo systemctl start hadoop-namenode hadoop-datanode hadoop-nodemanager hadoop-resourcemanager
Job for hadoop-datanode.service failed. See 'systemctl status hadoop-datanode.service' and 'journalctl -xn' for details.

$ systemctl status -l hadoop-datanode.service
hadoop-datanode.service - The Hadoop datanode daemon
   Loaded: loaded (/usr/lib/systemd/system/hadoop-datanode.service; enabled)
   Active: failed (Result: exit-code) since Wed 2013-12-18 16:34:51 PST; 9min ago
  Process: 1358 ExecStop=/usr/sbin/hadoop-daemon.sh stop datanode (code=exited, status=0/SUCCESS)
  Process: 4240 ExecStart=/usr/sbin/hadoop-daemon.sh start datanode (code=exited, status=1/FAILURE)
 Main PID: 1205 (code=exited, status=1/FAILURE)

Dec 18 16:34:47 DreamCatcher hadoop-daemon.sh[4240]: starting datanode, logging to /var/log/hadoop-hdfs/hadoop-hdfs-datanode-DreamCatcher.out
Dec 18 16:34:51 DreamCatcher systemd[1]: hadoop-datanode.service: control process exited, code=exited status=1
Dec 18 16:34:51 DreamCatcher systemd[1]: Failed to start The Hadoop datanode daemon.
Dec 18 16:34:51 DreamCatcher systemd[1]: Unit hadoop-datanode.service entered failed state.

Note You need to log in before you can comment on or make changes to this bug.