Bug 1003153 - dracut growroot module leaves an empty directory around which breaks dracut
dracut growroot module leaves an empty directory around which breaks dracut
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cloud-initramfs-tools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juerg Haefliger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-31 04:34 EDT by Richard W.M. Jones
Modified: 2013-12-20 21:08 EST (History)
5 users (show)

See Also:
Fixed In Version: cloud-initramfs-tools-0.20-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 23:51:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-08-31 04:34:29 EDT
Description of problem:

If you install dracut-modules-growroot then uninstall it, it leaves
an unowned directory around (/usr/lib/dracut/modules.d/50growroot).
This then breaks dracut.  I'll file a separate bug about that.

Version-Release number of selected component (if applicable):

dracut 029-1.fc19

How reproducible:

At least once.

Steps to Reproduce:
1. Install and uninstall dracut-modules-growroot.
2. Observe directory is not deleted.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Harald Hoyer 2013-09-02 04:31:23 EDT
So, this bug is against which component???

https://bugzilla.redhat.com/show_bug.cgi?id=1003154
Comment 3 Richard W.M. Jones 2013-09-02 07:00:17 EDT
(In reply to Harald Hoyer from comment #2)
> So, this bug is against which component???
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1003154

Ah, didn't realize that dracut-modules-growroot was
in a different component.  Changed.

This seems to be a bug in the spec file, specifically
an unowned directory:

%files -n dracut-modules-growroot
%doc COPYING README growroot/doc/example.txt
%if 0%{?fedora}
%{_prefix}/lib/dracut/modules.d/50growroot/growroot.sh
%{_prefix}/lib/dracut/modules.d/50growroot/module-setup.sh
%else
%if 0%{?rhel}
%{_prefix}/share/dracut/modules.d/50growroot/growroot.sh
%{_prefix}/share/dracut/modules.d/50growroot/install
%endif
%endif

There should be a %dir %{_prefix}/share/dracut/modules.d/50growroot
directive in there.
Comment 4 Fedora Update System 2013-11-22 08:10:03 EST
cloud-initramfs-tools-0.20-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/cloud-initramfs-tools-0.20-2.fc20
Comment 5 Fedora Update System 2013-11-22 08:28:05 EST
cloud-initramfs-tools-0.20-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cloud-initramfs-tools-0.20-2.fc19
Comment 6 Fedora Update System 2013-11-22 08:39:56 EST
cloud-initramfs-tools-0.20-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/cloud-initramfs-tools-0.20-2.el6
Comment 7 Fedora Update System 2013-11-22 21:38:40 EST
Package cloud-initramfs-tools-0.20-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing cloud-initramfs-tools-0.20-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-12173/cloud-initramfs-tools-0.20-2.el6
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-11-25 23:51:28 EST
cloud-initramfs-tools-0.20-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-12-20 11:52:36 EST
cloud-initramfs-tools-0.20-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-12-20 21:08:57 EST
cloud-initramfs-tools-0.20-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.