Bug 1003154 - dracut is broken if there's an empty /usr/lib/dracut/modules.d directory
dracut is broken if there's an empty /usr/lib/dracut/modules.d directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-31 04:36 EDT by Richard W.M. Jones
Modified: 2014-01-07 08:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-07 08:37:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-08-31 04:36:26 EDT
Description of problem:

See bug 1003153.  Uninstalling a module left an empty directory
in /usr/lib/dracut/modules.d.  After that, dracut would no longer
work:

I: *** Including module: i18n ***
I: *** Including module: drm ***
I: *** Including module: growroot ***
F: installkernel failed in module growroot

Deleting the directory fixed dracut.  However dracut should be
more robust in this case.  It should give a warning, naming the
empty directory, but should not fail.

Version-Release number of selected component (if applicable):

dracut 029-1.fc19

How reproducible:

100%

Steps to Reproduce:
1. Create an empty directory under /usr/lib/dracut/modules.d
2. Try to run dracut.
3.

Actual results:

Fails, unnecessarily.

Expected results:


Additional info:
Comment 2 Richard W.M. Jones 2013-09-02 06:55:42 EDT
Patch looks good to me.
Comment 3 Richard W.M. Jones 2013-12-21 04:50:18 EST
Since the patch is upstream, we can close this bug now, right?

Note You need to log in before you can comment on or make changes to this bug.