Bug 1003324 - libgexiv2-0.7.0 is available
libgexiv2-0.7.0 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libgexiv2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ankur Sinha (FranciscoD)
Fedora Extras Quality Assurance
: FutureFeature, Triaged
: 1016229 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-01 18:06 EDT by Upstream Release Monitoring
Modified: 2013-10-15 02:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: libgexiv2-0.7.0-1.fc20
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 02:42:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2013-09-01 18:06:32 EDT
Latest upstream release: 0.7.0pr1
Current version/release in Fedora Rawhide: 0.6.1-2.fc20
URL: http://yorba.org/download/gexiv2/0.7/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Upstream Release Monitoring 2013-09-23 05:17:46 EDT
Latest upstream release: 0.7.0pr2
Current version/release in Fedora Rawhide: 0.6.1-2.fc20
URL: http://yorba.org/download/gexiv2/0.7/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 2 Kalev Lember 2013-09-29 08:04:39 EDT
I can help with rebuilds for F20 if you want to push the update out.
Comment 3 Ankur Sinha (FranciscoD) 2013-09-29 09:46:11 EDT
I'm not sure about this one. It's only a pre-release, and even the NEWS file hasn't been updated:

http://redmine.yorba.org/projects/gexiv2/repository/revisions/master/entry/NEWS

It looks like an ABI change to 3.0.0 caused this pre-release:
http://git.yorba.org/cgit.cgi/gexiv2/commit/?id=16568949c50d7f588178566e7449c25c1a3e92f6

I'd rather wait for the actual 0.7 release personally. What do you think Kalev?

Thanks,
Ankur
Comment 4 Kalev Lember 2013-09-29 10:29:09 EDT
> I'm not sure about this one. It's only a pre-release, and even the NEWS file
> hasn't been updated:

Seems to be the same for other Yorba projects -- no updated NEWS for Shotwell pre-releases either.

(F20 now has https://admin.fedoraproject.org/updates/shotwell-0.15.0-0.1.pr3.fc20 by the way)


> It looks like an ABI change to 3.0.0 caused this pre-release:
> http://git.yorba.org/cgit.cgi/gexiv2/commit/
> ?id=16568949c50d7f588178566e7449c25c1a3e92f6

Err, this looks wrong. The commit that this links to adds a new symbol, but this is usually _not_ considered an ABI change and shouldn't warrant a soname bump.

I'll open a ticket and ask about this.


Also, I've noticed that we have a downstream libgexiv2-pkgconf.patch. Do you know what's up with this, and could you maybe submit it upstream? Or ask whoever commited this to submit it upstream?
Comment 5 Kalev Lember 2013-09-29 10:45:00 EDT
http://redmine.yorba.org/issues/7557

Would probably make sense to hold off the update until this is resolved one way or the other.
Comment 6 Kalev Lember 2013-10-02 04:42:18 EDT
The soname bump is now reverted in gexiv2 git master.
Comment 7 Kalev Lember 2013-10-07 04:01:53 EDT
The final release is out now:

http://yorba.org/download/gexiv2/0.7/libgexiv2-0.7.0.tar.xz
Comment 8 Ankur Sinha (FranciscoD) 2013-10-07 09:20:57 EDT
Ah! Great!

I'll update the package tomorrow and drop a mail to the devel list. It'll be great if you can help with the rebuilds whenever you have the cycles Kalev.

Thanks again,
Warm regards,
Ankur
Comment 9 Kalev Lember 2013-10-07 09:26:22 EDT
The soname bump was reverted, I don't think there's a need to rebuild other packages. Should be just a straightforward update now.
Comment 10 Ankur Sinha (FranciscoD) 2013-10-07 19:06:32 EDT
*** Bug 1016229 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2013-10-07 19:54:51 EDT
libgexiv2-0.7.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libgexiv2-0.7.0-1.fc20
Comment 12 Fedora Update System 2013-10-09 10:31:30 EDT
Package libgexiv2-0.7.0-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libgexiv2-0.7.0-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18550/libgexiv2-0.7.0-1.fc20
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2013-10-15 02:42:53 EDT
libgexiv2-0.7.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.