Bug 10034 - Emulate 3 buttons not selected in installer, still configured in XF86Config
Emulate 3 buttons not selected in installer, still configured in XF86Config
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-07 13:18 EST by Hans de Goede
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-14 12:05:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-03-07 13:18:19 EST
No matter what setting you select for emulate 3 buttons in the graphical
installer, the generated XF86Config contained the setting used by the
installer (the default setting for the kind of mouse it autoprobed).

The installer used to have the same problem fot the type of mouse selected,
no matter what type of mouse you selected it put the type used during the
install in XF86Config (Bug 8754).

The generated /etc/sysconfig/mouse file is fine, the problem is the
XF86config generation using the values active during the install, not the
ones configured by the user.
Comment 1 Vilius Puidokas 2000-03-28 16:57:59 EST
also, there's something broken with kickstart and 'emulthree'.
crashes with:

File "...kickstart.py" line 228, in doMouse (args, extra) = isys.getopt(args,
'', [ 'device=', 'emulthree' ])

TypeError: bad argument --kickstart: unknown option
Comment 2 Vilius Puidokas 2000-04-11 13:53:59 EDT
--kickstart not needed anymore, just one of these little gotchas in 6.2
well done on docs.
Comment 3 Jay Turner 2000-04-17 14:56:59 EDT
Not able to replicate in test lab.
Comment 4 Hans de Goede 2000-04-26 17:21:59 EDT
Well, it took me 2 installs ;| But I've managed to reprudce it, here is how:
-Take a system with an microsoft intelli mouse
-Do a normal straigth forward install.
-When it asks for the mouse, select microsoft intelli mouse
-It enables emulate 3 buttons, this is rong, turn it of (already mentioned
 in a sperate bug report)
-continue install using all defaults

Now check /etc/sysconfig/mouse, this one is correct, no emulate 3 buttons,
/etc/X11/XF86Config however does have emulate 3 buttons turned on, which IMHO is
a bug.
Comment 5 Jay Turner 2000-04-27 10:07:59 EDT
Forwarding this to a developer for further action.
Comment 6 Michael Fulbright 2000-06-12 14:21:09 EDT
Please verify against developmental release.
Comment 7 Hans de Goede 2000-06-14 12:05:25 EDT
Ok, I've checked this against 6.9.0 beta1, and its gone, so I'm resolving and
closing it.


Note You need to log in before you can comment on or make changes to this bug.