Bug 1003472 - qemu-img convert -p option display error
qemu-img convert -p option display error
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Max Reitz
Virtualization Bugs
:
Depends On:
Blocks: 1006681
  Show dependency treegraph
 
Reported: 2013-09-02 03:05 EDT by Xu Han
Modified: 2017-07-03 23:15 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1006681 (view as bug list)
Environment:
Last Closed: 2014-01-13 13:50:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xu Han 2013-09-02 03:05:27 EDT
Description of problem:
when qemu-img finish convert, image could be use, but display was (98.25/100%) not (100.00/100%).

Version-Release number of selected component (if applicable):
kernel: 3.10.0-12.el7.x86_64
qemu: qemu-kvm-1.5.3-1.el7.x86_64
      qemu-img-1.5.3-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.convert image
#qemu-img convert -f qcow2 win2012-x64.qcow2 -O raw win2012-x64.raw -p

Actual results:
qemu-img display:
(98.25/100%)

Expected results:
qemu-img display:
(100.00/100%)

Additional info:
in rhel6 host, this command display properly.
Comment 2 Max Reitz 2013-12-13 12:21:20 EST
Do you have any image for me to test this, by any chance? If I use RHEL7's qemu-img convert on a RHEL7 image I have here, it works properly.
Comment 3 juzhang 2013-12-15 21:20:41 EST
(In reply to Max Reitz from comment #2)
> Do you have any image for me to test this, by any chance? If I use RHEL7's
> qemu-img convert on a RHEL7 image I have here, it works properly.

Hi Xu,

Can you have a look and add comment?

Best Regards,
Junyi
Comment 4 Xu Han 2013-12-15 21:52:32 EST
Just re-tested few times with 'qemu-img-1.5.3-21.el7.x86_64', could not reproduce as well.

# qemu-img convert -f qcow2 RHEL-7.0-x86_64-Server.qcow2 -O raw RHEL-7.0-x86_64-Server.raw -p
    (100.00/100%)
# qemu-img convert -f qcow2 RHEL-6.5-x86_64-Server.qcow2 -O raw RHEL-6.5-x86_64-Server.raw -p
    (100.00/100%)
# qemu-img convert -f qcow2 Windows-7-x86-Desktop.qcow2 -O raw Windows-7-x86-Desktop.raw -p
    (100.00/100%)
# qemu-img convert -f qcow2 Windows-2012R2-x86_64-Server.qcow2 -O raw Windows-2012R2-x86_64-Server.raw -p
    (100.00/100%)
# qemu-img convert -f raw Windows-2012R2-x86_64-Server.raw -O qcow2 -o compat=0.10 Windows-2012R2-x86_64-Server.qcow2_v1 -p
    (100.00/100%)
# qemu-img convert -f raw RHEL-7.0-x86_64-Server.raw -O qcow2 RHEL-7.0-x86_64-Server.qcow2_v3 -p
    (100.00/100%)
Comment 5 Ademar Reis 2014-01-13 13:50:00 EST
based on recent comments, closing as WORKSFORME

Note You need to log in before you can comment on or make changes to this bug.