Bug 1006681 - qemu-img convert -p option display error
qemu-img convert -p option display error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On: 1003472
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 01:46 EDT by Sibiao Luo
Modified: 2015-07-22 02:03 EDT (History)
13 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.456.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1003472
Environment:
Last Closed: 2015-07-22 02:03:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Sibiao Luo 2013-09-11 01:49:15 EDT
Also met this issue in rhe6.5 host.

host info:
# uname -r && rpm -q qemu-kvm-rhev 
2.6.32-414.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.400.el6.x86_64

# qemu-img convert -p -f vhdx sluo-win2012-64bit.vhdx -O qcow2  sluo-win2012-64bit.qcow2
    (98.25/100%)
# qemu-img check sluo-win2012-64bit.qcow2
No errors were found on the image.
Image end offset: 8431927296
Comment 2 Sibiao Luo 2013-09-12 03:56:03 EDT
Aslo tried the rhel6.4GA that also this issue, so it's not a regression issue.

host info:
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.355.el6_4.7.x86_64

Steps and Results:
# qemu-img info win7-64.qcow2
image: win7-64.qcow2
file format: qcow2
virtual size: 30G (32212254720 bytes)
disk size: 8.1G
cluster_size: 65536
# qemu-img convert -p -f qcow2 win7-64.qcow2 -O raw win7-64.raw
    (98.25/100%)

Best Regards,
sluo
Comment 5 Jeff Nelson 2015-03-04 11:17:53 EST
Fix included in qemu-kvm-0.12.1.2-2.456.el6
Comment 7 Qian Guo 2015-03-11 04:57:40 EDT
Reproduce this bug with qemu-kvm-0.12.1.2-2.454.el6.x86_64

# qemu-img convert -f qcow2 rhel6.7cp1.qcow2 -O raw rhel6.7_repro.raw -p
    (98.25/100%)


Verify this bug with qemu-kvm-0.12.1.2-2.457.el6.x86_64

# qemu-img convert -f qcow2 rhel6.7cp1.qcow2 -O raw rhel6.7.raw -p
    (100.00/100%)


So this bug is fixed.
Comment 10 errata-xmlrpc 2015-07-22 02:03:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1275.html

Note You need to log in before you can comment on or make changes to this bug.