Bug 1003611 - storage nodes cannot complete handshake
storage nodes cannot complete handshake
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Installer (Show other bugs)
4.9
x86_64 Linux
unspecified Severity urgent (vote)
: ---
: RHQ 4.9
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 951619 999508
  Show dependency treegraph
 
Reported: 2013-09-02 09:30 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-02 12:14:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cannot-handshake.png (391.95 KB, image/png)
2013-09-02 09:30 EDT, Armine Hovsepyan
no flags Details
storage-node-outboundTcpConnection.png (549.73 KB, image/png)
2013-09-02 09:32 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description Armine Hovsepyan 2013-09-02 09:30:39 EDT
Created attachment 792848 [details]
cannot-handshake.png

Description of problem:
storage nodes cannot complete handshake

Version-Release number of selected component (if applicable):
a9245fd

How reproducible:
2 out of 2

Steps to Reproduce:
1. create rhq-storage.properties file with the following data in it:
client-port=$client-port
storage-port=$storage_port
seeds=IP1,IP2,IP3
start=false
2. on each 3 machines run 
3.  ./rhq-server-4.9.0-SNAPSHOT/bin/rhqctl install --storage --storage-config=/path/to/rhq-storage.properties --agent-preference="rhq.agent.server.bind-address=$IP1"  --agent-auto-start false
4. edit rhq-server-4.9.0-SNAPSHOT/rhq-storage/conf/rhq-storage-auth.conf and add the following into it:
IP1
IP2
IP3
5. run rhqctl start on all 3 machines
6. run rhqctl install --server on IP1

Actual results:
2 of storage nodes cannot complete handshake

Expected results:
all 3 nodes finis handshaking, create a cluster with shared properties, all 3 discovered in server GUI and are available

Additional info:
screen-shot attached
Comment 1 Armine Hovsepyan 2013-09-02 09:32:40 EDT
Created attachment 792849 [details]
storage-node-outboundTcpConnection.png
Comment 2 Armine Hovsepyan 2013-09-02 12:14:24 EDT
thanks John Sanda for investigation

closing a not a bug - rhq-server.properties was not configured correctly

Note You need to log in before you can comment on or make changes to this bug.