Bug 1003629 - VM operating system stuck (Windows) during successful live disk resize with VirtIO disk
VM operating system stuck (Windows) during successful live disk resize with V...
Status: CLOSED DUPLICATE of bug 926947
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Linux
high Severity urgent
: ---
: 3.3.0
Assigned To: Vadim Rozenfeld
Haim
storage
: Triaged
: 1003632 (view as bug list)
Depends On: 926947 1015872
Blocks: 600483 1019461
  Show dependency treegraph
 
Reported: 2013-09-02 10:11 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 12:48 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 03:34:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: needinfo+
scohen: needinfo+
abaron: Triaged+


Attachments (Terms of Use)
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm (4.46 MB, application/x-gzip)
2013-09-02 10:11 EDT, vvyazmin@redhat.com
no flags Details
online resize logs (2.17 MB, application/gzip)
2013-10-03 09:27 EDT, Sean Cohen
no flags Details
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm (2.17 MB, application/x-gzip)
2013-10-06 06:22 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2013-09-02 10:11:55 EDT
Created attachment 792857 [details]
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm

Description of problem:
Failed live resize VM disk (VirtIO disk type) with Windows OS installed on it

Version-Release number of selected component (if applicable):
RHEVM 3.3 - IS12 environment:

RHEVM:  rhevm-3.3.0-0.18.master.el6ev.noarch
PythonSDK:  rhevm-sdk-python-3.3.0.12-1.el6ev.noarch
VDSM:  vdsm-4.12.0-92.gita04386d.el6ev.x86_64
LIBVIRT:  libvirt-0.10.2-18.el6_4.9.x86_64
QEMU & KVM:  qemu-kvm-rhev-0.12.1.2-2.355.el6_4.7.x86_64
SANLOCK:  sanlock-2.8-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. On FCP Data Center create VM with VirtIO disk type and 20 GB disk size
2. Install Windows OS (Windows 7 or Windows 2008). Finish installation process.
3. During running VM resize VM’s disk size to 25GB

Actual results:
OS stuck

Expected results:
Successfully run live resize VM disk, without OS stuck.

Impact on user:
Can’t work with VM

Workaround:
Do cold resize VM disk. Power Off OS, resize VM disk, Power On VM.

Additional info:
* Live resize VM disk work ok with Linux OS
* Failed live resize VM disk with Windows OS on RAW and QCOW2 disks

/var/log/ovirt-engine/engine.log

/var/log/vdsm/vdsm.log
Comment 1 Ayal Baron 2013-09-15 10:27:37 EDT
*** Bug 1003632 has been marked as a duplicate of this bug. ***
Comment 7 Sean Cohen 2013-10-03 09:27:50 EDT
Created attachment 807083 [details]
online resize logs
Comment 9 Ronen Hod 2013-10-03 10:14:36 EDT
(In reply to Sean Cohen from comment #8)

Hi Sean,

Since we are talking about a BSOD, we need more focus on the Windows side of this bug.
Can you provide us a memory dump from C:\Windows\memory.dmp.
If it is not there, please enable it from System Properties -> advanced, and in the meantime send the latest file from C:\Windows\minidump
The file is big. Please Zip it, and put it somewhere where we can access it.
And since we are not familiar with it, what exactly is "Try resize disk"? Can you describe the failure? Is it really a BSOD? What is the Error's code and text?

Thanks, Ronen.
Comment 10 Sean Cohen 2013-10-06 02:11:17 EDT
Vladimir, please provide Ronen with the memory dump
Comment 13 vvyazmin@redhat.com 2013-10-06 06:21:42 EDT
Logs attached
Comment 14 vvyazmin@redhat.com 2013-10-06 06:22:13 EDT
Created attachment 808461 [details]
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm
Comment 23 Ronen Hod 2013-10-08 04:14:58 EDT
Since currently we are not talking about a Windows size BSOD, reassigning.

Ronen.
Comment 24 Federico Simoncelli 2013-10-08 04:25:44 EDT
(In reply to Ronen Hod from comment #23)
> Since currently we are not talking about a Windows size BSOD, reassigning.
> 
> Ronen.

The bug was opened as BSOD, reassigning this bug because QA encountered another regression during verification (bug 1015872) is only making confusion. The bug is already correctly depending on 1015872.
Comment 25 Ronen Hod 2013-10-08 05:44:51 EDT
QE,

Please check with both virtio-win build 72 and the bug fix from bug 1015872.
Comment 26 Aharon Canan 2013-10-08 05:52:08 EDT
we will wait for fix of 1015872
then retry to verify, 
as it is ON_QA removing needinfo from Vlad.
Comment 27 vvyazmin@redhat.com 2013-10-13 07:01:25 EDT
Used latest Windows Virt-IO Drivers:
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/72/win/virtio-win-prewhql-0.1.zip


Tested on FCP Data Centers
Verified, tested on RHEVM 3.3 - IS18 environment:

Host OS: RHEL 6.5

RHEVM:  rhevm-3.3.0-0.25.beta1.el6ev.noarch
PythonSDK:  rhevm-sdk-python-3.3.0.15-1.el6ev.noarch
VDSM:  vdsm-4.13.0-0.2.beta1.el6ev.x86_64
LIBVIRT:  libvirt-0.10.2-27.el6.x86_64
QEMU & KVM:  qemu-kvm-rhev-0.12.1.2-2.412.el6.x86_64
SANLOCK:  sanlock-2.8-1.el6.x86_64
Comment 28 Vadim Rozenfeld 2013-10-13 07:21:54 EDT
(In reply to vvyazmin@redhat.com from comment #27)
> Used latest Windows Virt-IO Drivers:
> http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/72/
> win/virtio-win-prewhql-0.1.zip
> 
> 
> Tested on FCP Data Centers
> Verified, tested on RHEVM 3.3 - IS18 environment:
> 
> Host OS: RHEL 6.5
> 
> RHEVM:  rhevm-3.3.0-0.25.beta1.el6ev.noarch
> PythonSDK:  rhevm-sdk-python-3.3.0.15-1.el6ev.noarch
> VDSM:  vdsm-4.13.0-0.2.beta1.el6ev.x86_64
> LIBVIRT:  libvirt-0.10.2-27.el6.x86_64
> QEMU & KVM:  qemu-kvm-rhev-0.12.1.2-2.412.el6.x86_64
> SANLOCK:  sanlock-2.8-1.el6.x86_64

Thanks,
Vadim.
Comment 31 Charlie 2013-11-27 19:33:11 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.