Bug 10039 - File /etc/ld.so.conf fails to include /usr/local/lib
File /etc/ld.so.conf fails to include /usr/local/lib
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: ldconfig (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
: 10019 182486 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-07 13:52 EST by David A. Wheeler
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-08 14:08:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David A. Wheeler 2000-03-07 13:52:14 EST
Various standards place dynamic libraries by default in /usr/local/lib.
This includes the coding standards for the entire GNU project; see
 info -> Standards -> Managing Releases -> Makefile Conventions ->
 Directory Variables.

However, /etc/ld.so.conf doesn't include /usr/local/lib, causing
many surprises when trying to download and install from sources.
None of this is necessary; you should be able to download & install
programs "automagically" without having to set prefixes, etc.
This is quite nonstandard, for example, Solaris always
includes /usr/local/lib in its directory list.

If "ldconfig" is the wrong package to blame, sorry; please forward it
to whoever is the "right" person.

In short: please add a "/usr/local/lib" entry to /etc/ld.so.conf.
Comment 1 Jeff Johnson 2000-03-08 14:08:59 EST
While adding /usr/local/lib is the Right Thing To do in the circumstances
you describe, Red Hat tries to leave /usr/local *entirely* to the local
system administrator, including configuring /usr/local in /etc/ld.so.conf.

The real issue is what should the default configuration be. Since Red Hat
can't possibly guess where /usr/local should be inserted, we do nothing.
Comment 2 Jeff Johnson 2000-03-08 14:14:59 EST
*** Bug 10019 has been marked as a duplicate of this bug. ***
Comment 3 Ignacio Vazquez-Abrams 2006-02-22 15:42:02 EST
*** Bug 182486 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.