Bug 1003946 - impl_qpid changes to allow use of qpid federation
impl_qpid changes to allow use of qpid federation
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
3.0
Unspecified Unspecified
high Severity medium
: beta
: 4.0
Assigned To: Eric Harney
Ami Jeain
:
Depends On: 1003937 1003951
Blocks: 1003938 1003942
  Show dependency treegraph
 
Reported: 2013-09-03 10:40 EDT by Russell Bryant
Modified: 2016-04-26 10:34 EDT (History)
14 users (show)

See Also:
Fixed In Version: openstack-cinder-2013.2-0.11.rc1.el6ost
Doc Type: Bug Fix
Doc Text:
Cause: Restarting services that are connected to qpidd. Consequence: A qpid exchange that was in use is not deleted, resulting in a leak of exchanges on the qpid broker Fix: This patch adds an option that allows you to switch OpenStack's qpid client code over to a different way of operating that solves this issue. It is an option because it is not backwards compatible with older versions of the code. Result: No more exchanges will be leaked on the qpid broker.
Story Points: ---
Clone Of: 1003937
Environment:
Last Closed: 2013-12-19 19:23:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rbryant: needinfo+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1178375 None None None Never

  None (edit)
Description Russell Bryant 2013-09-03 10:40:32 EDT
+++ This bug was initially created as a clone of Bug #1003937 +++

A patch was recently merged upstream to the impl_qpid rpc driver to allow the use of qpid federation.  It also completes the fix for leaking qpid exchanges.  Lastly, it includes a couple of additional options to allow durable and auto-delete for queues to be configurable.  Pulling in these options make for a cleaner backport.

The commits from oslo-incubator are:

76972e2 Support a new qpid topology
5ff534d Add config for amqp durable/auto_delete queues


These changes should be backported for RHOS 3.0.z.
Comment 11 Ami Jeain 2013-11-19 17:38:07 EST
verified:
1. made sure qpid_topology_version=2 in /usr/share/nova/nova-dist.conf and performing the following:
1. adding an image
2. creating an instance
3. creating a volume and attaching it to the instance
4. detaching and deleting the volume just created
watched the logs and making sure no errors appear

# rpm -qa |grep openstack-cinder
openstack-cinder-2013.2-2.el6ost.noarch
Comment 14 errata-xmlrpc 2013-12-19 19:23:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.